MATLAB Answers

PIL block not build for C2000

5 ビュー (過去 30 日間)
ashwinee jadhao
ashwinee jadhao 2019 年 3 月 8 日
Hello,
I am working on simulink, want to generate PIL block from the subsystem. whenever I tried to generate PIL block I am getting this on the diagnostics window:-
Generating code into build folder: D:\ASH_pc2\MATLAB_workspace\PANVA\mil_new\Subsystem1_ert_rtw
#4169 has an unconditional transition '{PM_State=1}' that shadows the following transitions: '[PM_Status== 5]' You can also configure the diagnostic by clicking here. [6 similar]
Component:Stateflow | Category:Coder warning
Junction #4178 does not have an unconditional path to a state or a terminal junction AND it has multiple paths leading to it. This might lead to confusing run-time behavior because of the backtracking semantics of Stateflow. In particular: 1. The transitions downstream of this junction might get executed multiple times (depending on the number of incident paths to this junction). 2. Execution might backtrack all the way to another transition upstream of this junction leading to execution of undesired transitions. To avoid this potentially confusing behavior, consider adding an unconditional transition to a terminal junction from this junction #4178. This will ensure that execution never backtracks from this junction. Type "sfhelp('backup_warning_error')" for more examples of undesirable backtracking semantics. You can also configure the diagnostic by clicking here. [9 similar]
Component:Stateflow | Category:Coder warning
The data 'Mode' has an 8 bit data type. However the 'Hardware Implementation' section of Configuration Parameters has no 8 bit data type. This may cause simulation results to not match code generation results in case the 8-bit computation overflows. [14 similar]
Component:Stateflow | Category:Coder warning
Model sample time is set to 1e-05 sec, which is longer than this threshold. Transition 'after(2,usec)' in Chart 'Subsystem1/Subsystem1/Chart': after(2,usec) [4 similar]
Component:Stateflow | Category:Coder warning
### Invoking Target Language Compiler on Subsystem1.rtw ### Using System Target File: C:\Program Files\MATLAB\R2018b\rtw\c\ert\ert.tlc ### Loading TLC function libraries ...... ### Generating TLC interface API for custom data .. ### Initial pass through model to cache user defined code ....... ### Caching model source code ............................................................................... ............................................................................... ........ ### Writing header file Subsystem1_types.h ### Writing source file Subsystem1.c ### Writing header file Subsystem1_private.h ### Writing header file Subsystem1.h . ### Writing header file rtwtypes.h ### Writing header file rtmodel.h ### TLC code generation complete. ### Evaluating PostCodeGenCommand specified in the model ### Using toolchain: Texas Instruments C2000 Code Generation Tools v16.9.2 | gmake (64-bit Windows) ### Creating 'D:\ASH_pc2\MATLAB_workspace\PANVA\mil_new\Subsystem1_ert_rtw\Subsystem1.mk' ... ### Successful completion of code generation for model: Subsystem1 ### Creating HTML report file Subsystem1_codegen_rpt.html
Build process completed successfully
But it not generating PIL model for the same. Please help me, I have tried many solutions but stuck
Thanks

回答 (0 件)

タグ

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by