MATLAB Answers

Window appears while code is runnig

1 ビュー (過去 30 日間)
Sergey Kasyanov
Sergey Kasyanov 2018 年 4 月 30 日
コメント済み: Sergey Kasyanov 2020 年 9 月 3 日
Hello,
I'm trying to create library with some SimPowerSystem blocks. When I use blocks from my library in Simulink model and initialize it by the command
LF=power_loadflow('-v2','model','solve');
in the script the next window appears.
How can I avoid that window by auto applying changes to the library? Or may be there is better way to initialize model with users libraries blocks?
Thanks.

  0 件のコメント

サインインしてコメントする。

回答 (1 件)

Joel Van Sickel
Joel Van Sickel 2020 年 9 月 2 日
Hello Sergey,
you can have library blocks automatically disconnect from a library when you add them to a model. This is not ideal because changes you make to the library won't be updated to these blocks, but it does solve this issue.
View this document and set link status to none: https://www.mathworks.com/help/simulink/ug/creating-block-libraries.html
Regards,
Joel

  1 件のコメント

Sergey Kasyanov
Sergey Kasyanov 2020 年 9 月 3 日
Thanks!
Also I can add that another way to avoid that problem is create complex blocks by functions (programming approach) not by the custom library. If you don't need to change reference block that way will be the best solution because it fast, flexible and give you full control of the block diagram.

サインインしてコメントする。

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by