Custom Arduino Library won't register.

7 ビュー (過去 30 日間)
Kevin Gilliam
Kevin Gilliam 2018 年 2 月 5 日
コメント済み: Nicolas Petit 2021 年 11 月 17 日
As the title suggests, I am trying to implement custom libraries with the Arduino support package, but I can't get them to register. I'm using 2017b on Windows 10. Support package is version 17.2.0.
I've tried with the three example tutorials (LCD, Ultrasonic, and HelloWorld), and no luck getting them to register.
I have definitely added my arduino libraries to the path, along with my working directory that has my package directories and .m files. I've un/re-installed the support packages (in admin mode and not) and no luck. I did the thing they suggest for troubleshooting here
Here is my HelloWorld.h file:
#include "LibraryBase.h"
class HelloWorld : public LibraryBase {
public:
HelloWorld(MWArduinoClass& a){
libName = "ExampleAddon/HelloWorld";
a.registerLibrary(this);
}
public:
void commandHandler(byte cmdID, byte* dataIn, unsigned int payloadSize){
switch (cmdID){
case 0x01:{
byte val [13] = "Hello World";
sendResponseMsg(cmdID, val, 13);
break;
}
default:{
// Do nothing
}
}
}
}
And here is my HelloWorld.m:
classdef HelloWorld < arduinoio.LibraryBase
properties(Access = private, Constant = true)
READ_COMMAND = hex2dec('01')
end
properties(Access = protected, Constant = true)
LibraryName = 'ExampleAddon/HelloWorld'
DependentLibraries = {}
ArduinoLibraryHeaderFiles = {}
CppHeaderFile = fullfile(arduinoio.FilePath(mfilename('fullpath')), 'src', 'HelloWorld.h')
CppClassName = 'HelloWorld'
end
methods
function obj = HelloWorld(parentObj)
obj.Parent = parentObj;
obj.Pins = [];
end
function out = read(obj)
cmdID = obj.READ_COMMAND;
inputs = [];
output = sendCommand(obj, obj.LibraryName, cmdID, inputs);
out = char(output);
end
end
end
No matter what I try, the end result is always the same:
6×1 cell array
{'Adafruit/MotorShieldV2'}
{'I2C' }
{'RotaryEncoder' }
{'SPI' }
{'Servo' }
{'ShiftRegister' }
Any thoughts? Thanks!
  1 件のコメント
Madhu Govindarajan
Madhu Govindarajan 2018 年 2 月 5 日
So when you say you tried the example tutorials LCD one - are you referring to this one here - https://www.mathworks.com/help/supportpkg/arduinoio/ug/add-lcd-library.html
If so, have you confirmed that when you are adding the files to the path that the subfolders are being included?
Are you getting any error messages/warning messages that are suppressed while you are following these tutorials?

サインインしてコメントする。

採用された回答

Menghan
Menghan 2018 年 2 月 5 日
Hi Kevin,
I know you have tried with the example add-on, but just to confirm it again, can you run the following code in MATLAB where you have the support package installed?
>>addpath(fullfile(arduinoio.SPPKGRoot,'arduinoioexamples','SDKExampleHelloWorld'))
>>listArduinoLibraries
See if you get the HelloWorld addon registered. If not, please contact our Technical Support to get further help.
On a side note, you are missing a semicolon at the end of your class definition in the HelloWorld.h file. Each C++ class ends with it. It will cause arduino programming to fail, after the library register issue is solved.
Thanks,
Menghan
MATLAB Hardware Team
  3 件のコメント
Nicolas Petit
Nicolas Petit 2021 年 11 月 17 日
same thing. This does not work

サインインしてコメントする。

その他の回答 (0 件)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by