Problem linking RefProp to MatLab

142 ビュー (過去 30 日間)
Martin Olafsen
Martin Olafsen 2017 年 12 月 8 日
I am trying to connect RefProp(V9.1) to MatLab(V2016b). I have followed two guides ( Here from GitHub and Here from NIST). I have downloaded the files:
  • refpropm.m
  • REFPRP64.dll
  • refprop.h
  • REFPRP64_thunk_pcwin64.dll
  • rp_proto64.m
I have tried having them both in the RefProp directory and in a separate folder, but to no avail. I linked MatLab to the folders when I was testing. I always get the same error.
>> testVal=refpropm('T', 'P', 101.325, 'Q', 0, 'water')
Error using loadlibrary
Too many input arguments.
Error in ==>@()rp_proto64(BasePath) at 211
There was an error running C:\Program Files (x86)\REFPROP\refpropm.m.
Run @()rp_proto64(BasePath) from the command line to reproduce the error and fix it.
Error in refpropm (line 227)
Caused by:
Error using rp_proto64
Too many input arguments.
Has anyone had the same error and solved it? Any suggestions?
Thank you for any help
  5 件のコメント
Cahya Amalinadhi Putra
Cahya Amalinadhi Putra 2020 年 10 月 1 日
@priyanshu chhabra , I experienced the same problem here. You should move the 'rp_proto64.m' to the same directory as your <working>.m file. Then try to run the <working>.m again. You should not experience the error again.


回答 (1 件)

Li Yucen
Li Yucen 2019 年 6 月 9 日
1.Try to upload the Matlab and Refprop to latest version, I used 10.0 NIST and R2018b MTABLAB.
2. Involve all of them. Try to google and download the REFPROP.DLL, REFPROP64.DLL,REFPROP64.LIB, and five functions.
  1 件のコメント
yuer xiao
yuer xiao 2020 年 5 月 27 日
refprop64.dll, REFPRP64_thunk_pcwin64.dll, refpropm.m, rp_proto64.m



Find more on Parallel Computing in Help Center and File Exchange


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by