MATLAB Answers

Error using xlsread (line 260)

62 ビュー (過去 30 日間)
Adriano
Adriano 2017 年 5 月 8 日
Commented: dpb 2017 年 5 月 9 日
Hello! Today "xlsread" function give me this error:
Error using xlsread (line 260)
Undefined function 'Activate' for input arguments of type 'Interface.000208D8_0000_0000_C000_000000000046'.
I have used xlsread many times and now it doesn't work. I tried to use xlsread on many excel files but the problem persists. The code I execute is very simple:
filename2 = 'C:\one.xlsm';
[data,names] = xlsread(filename2,'tool');
What can I do? many thanks!

  3 件のコメント

dpb
dpb 2017 年 5 月 8 日
Restart Matlab for starters...
Looks like a registration problem on internals, maybe.
>> which Activate
Activate is a built-in method % Interface.Microsoft_Excel_9.0_Object_Library._Workbook method
>>
What happens if you try above?
Guillaume
Guillaume 2017 年 5 月 8 日
I doubt that restarting matlab would make a difference, but you never know...
Most likely, the problem is with Excel, which for some reason, returned a worksheet to matlab that is not really a worksheet. Has any change been made to Excel?
dpb
dpb 2017 年 5 月 8 日
Indeed, but it's an easy thing to try...but you're right it's probably something to do w/ Excel
Guess it never hurts to ask about version and so...

サインイン to comment.

採用された回答

Santhana Raj
Santhana Raj 2017 年 5 月 9 日
編集済み: dpb 2017 年 5 月 9 日

  1 件のコメント

dpb
dpb 2017 年 5 月 9 日
There's a half-dozen or so different symptoms/fixes there...which one, specifically solved your issue might be worth noting.

サインイン to comment.

More Answers (0)

サインイン してこの質問に回答します。

タグ


Translated by