Problem with roll centre subsystem

1 ビュー (過去 30 日間)
jake humphrey
jake humphrey 2017 年 4 月 6 日
Moved: Steve Miller 2022 年 12 月 7 日
I have used the physical modelling for automotive teams tutorials to build a simple suspension model to be used for kinematic analysis, because of this I have fixed the chassis in position by removing the degree of freedom subsystem. This however has caused a problem with the roll centre calculations as it is showing no change in the roll centre height even though the instant centres are moving. Any help would be appreciated thank you.
  2 件のコメント
jake humphrey
jake humphrey 2017 年 4 月 10 日
Thanks for the suggestion, however I am still getting problems. The roll centre does move now however it is a movement in the y direction rather than the z direction which shouldn't happen as the suspension is symmetrical and the movement is the same on both left and right. I have uploaded the updated model and would appreciate it if you could take a look and see if you can find the problem, Thank you

サインインしてコメントする。

回答 (1 件)

Swarooph
Swarooph 2017 年 4 月 19 日
Moved: Steve Miller 2022 年 12 月 7 日
Hello Jake,
I apologize for the delay. Anyway, I think we may have solved this problem. Great job changing all the subsystems to the right rigid transform translations. We missed two more of them. They were the rigid transform blocks in the Force Test subsystems. Example screenshot below.
You can also take a look at the RC Scope and see that the center is moving only in the vertical direction as shown by the blue line below.
I have also attached the files. Let me know if this was the fix you are looking for.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by