How do I troubleshoot issues with disabling the Windows Hyper-V feature for Simulink Desktop Real-Time?

195 ビュー (過去 30 日間)
I tried to turn the Hyper-V feature off in Windows 10 by following the steps in this MATLAB Answers post:
However, my Simulink Desktop Real-Time simulation still doesn't work. How can I resolve this issue?


MathWorks Support Team
MathWorks Support Team 2022 年 7 月 26 日
編集済み: MathWorks Support Team 2022 年 9 月 15 日
We suspect that Hyper-V is still enabled. Try the following steps:
(1) Make sure that you have restarted the computer after disabling the Hyper-V settings in the Windows feature list.
(2) After the restart, run the "systeminfo" command from Windows Command Prompt (CMD) or from MATLAB:
>> !systeminfo
In case Hyper-V is still enabled, you will see the following output:
Hyper-V Requirements: A hypervisor has been detected. Features required for Hyper-V will not be displayed.
Try to repeat the steps from the troubleshooting guide to disable Hyper-V. Again, make sure to restart your PC:
(3) You may also have to disable additional features that use the Microsoft virtualization technology, for example:
* Windows Subsystem for Linux
* Windows Hypervisor Platform
* Virtual Machine Platform
(4) Some of our customers reported that disabling Intel or AMD Virtualization support in the BIOS resolved the issue. See the following link for more info regarding Intel Virtualization:
(5) We are aware of cases where disabling Hyper-V in the Windows feature list will not work, even after multiple attempts, and the Hyper-V feature will still be shown as enabled by "systeminfo". In this case, contact your IT helpdesk to disable Hyper-V on your machine.
(6) If your company's IT policies do not allow disabling Hyper-V, then you will not be able to use Simulink Desktop Real-Time on this machine. Our recommendation is to talk to your IT helpdesk to get access to an "offline" machine that does not have to follow the company's IT policies. Also, note that other hypervisors such as VMware Workstation will work with Simulink Desktop Real-Time.

    その他の回答 (1 件)

    Nathan Hardenberg
    Nathan Hardenberg 2022 年 10 月 11 日
    The accepted solution did not work for me. I found the solution for my problem here:
    "Go to Settings > Privacy & Security > Device Security > Core Isolation > Memory Integrity = OFF"
    You have to restart the computer afterwards.
    (My system is an Windows 11 Computer)


    Find more on Troubleshooting in Simulink Desktop Real-Time in Help Center and File Exchange

    Community Treasure Hunt

    Find the treasures in MATLAB Central and discover how the community can help you!

    Start Hunting!

    Translated by