ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

モデル エクスプローラーを使用した検索と編集

モデル エクスプローラーで実行可能な処理

モデル エクスプローラーを使用すると、Simulink® モデル、Stateflow® チャートおよびワークスペース変数の要素を表示、変更および追加できます。モデル エクスプローラーを使うと、モデルやチャート内を移動することなく、特定の要素 (ブロック、信号、プロパティなど) に注目できます。

モデル エクスプローラーを使用して、以下を検索します。

  • ワークスペースおよびデータ ディクショナリの変数

  • モデル内における変数の使用

  • ブロック タイプのインスタンス

  • ブロック パラメーターとパラメーターの値

検索条件を組み合わせて、反復的に結果を絞り込むことができます。モデル エクスプローラーでのモデル要素の検索を、モデルの階層構造内で選択したノードから開始します。モデル全体、特定のシステム内、または 1 つのシステムと階層内でそのシステムの下にあるすべてのシステム内を検索できます。オプションの詳細については、検索バーのコントロールを参照してください。

パラメーターの検索方法を示す例については、モデル エクスプローラーを使用した検索を参照してください。

検索結果を使用して、複数の要素に対して変更を一度に適用できます。

モデルのデータ (ブロック パラメーター、信号、状態) を検索と並べ替えが可能なテーブルで操作するには、モデル データ エディターの使用を検討してください。パラメーターの値、信号の名前、状態の初期値などのデータ属性を指定できます。モデル データ エディターを使用したデータ プロパティの設定を参照してください。

データ ディクショナリでエントリを作成、変更、表示するには、モデル エクスプローラーを使用します。モデル エクスプローラーを使用したワークスペース変数の編集と管理およびディクショナリ データの変更表示と変更取り消しを参照してください。

モデル エクスプローラーを開いてオブジェクト プロパティを編集する

モデル エクスプローラーを開くには、次のいずれかの方法を使用します。

  • Simulink エディターの [ツール表示] メニューで、[モデル エクスプローラー] を選択するか、ツール バーでモデル エクスプローラー アイコン を選択します。

  • Simulink エディターで開かれているモデル内で、ブロックを右クリックし、コンテキスト メニューから [エクスプローラー] を選択します。

  • 開いている Stateflow チャート内の描画領域内を右クリックし、コンテキスト メニューから [エクスプローラー] を選択します。

  • MATLAB® コマンド ラインで「daexplr」と入力します。

オブジェクト プロパティを表示および編集するには、次のワークフローを使用します。

  1. 現在のシステムのみを表示するか、システムの階層構造全体を表示するかを指定するために、[モデルの階層構造] ペインでモデルを選択します。

  2. [コンテンツ] ペインに表示されるモデル情報を制御します。

    • [表示][列ビュー] オプションを使用して、表示するプロパティ列を制御します。

    • [表示][行フィルター] オプションを使用して、表示するオブジェクトの種類を制御します。

    • 列見出しを直接操作します。

  3. 検索バーを使用して、特定の値をもつモデルの要素を識別します。

  4. モデルの要素の値を [コンテンツ] ペインまたは [ダイアログ] ペインで編集します。ワークスペース変数を編集するには、変数エディターが使用できます。

検索バーのコントロール

[表示]、[ツール バー]、[検索バー] オプションを使用して検索バーを開きます。検索バーには以下のようなコントロールが含まれています。

検索タイプ

[検索タイプ] コントロールを使用して、検索に含めるオブジェクトまたはプロパティのタイプを指定します。

検索タイプのオプション説明
名前指定された文字列をオブジェクトの名前に含んでいるすべてのオブジェクトのモデルまたはチャートを検索します。検索文字列を参照してください。
プロパティ名指定されたプロパティをもつオブジェクトを検索します。検索ドメイン内のオブジェクトに対して設定可能なプロパティのリストからターゲット プロパティ名を指定します。
プロパティ値

指定した値に一致するプロパティ値をもつオブジェクトを検索します。プロパティの名前、一致させる値、および一致タイプ (equals、less than、greater than など) を指定します。検索文字列を参照してください。

ブロック タイプ

指定されたブロック タイプのブロックを検索します。現在選択されているモデルに含まれているタイプのリストからターゲットのブロック タイプを選択します。

Stateflow タイプ

指定されたタイプの Stateflow オブジェクトを検索します。

変数の使用

ワークスペースに定義されている変数を使用するブロックを検索します。ベース ワークスペースまたはモデル ワークスペース (モデル名) を選択し、必要に応じて変数名を指定します。検索文字列を参照してください。

参照された変数

モデルまたはブロックが使用する変数を検索します。[システム別] フィールドでそのモデルまたはブロックの名前を指定します。指定するモデルまたはブロックは [モデルの階層構造] ペイン内に存在しなければなりません。

使用されない変数

ワークスペースに定義されているが、モデルやブロックでは使用されていない変数を検索します。[ワークスペース内] フィールドのドロップダウン リストからワークスペースの名前を選択します。

ライブラリ リンク

現在のモデルのライブラリ リンクを検索します。

クラス

指定されたクラスの Simulink オブジェクトを検索します。

固定小数点機能

固定小数点の計算をサポートしているすべてのブロックのモデルを検索します。

モデル参照

モデルで他のモデルに対する参照を検索します。

ダイアログのプロンプト

指定したプロンプトをダイアログに含んでいるすべてのオブジェクトのモデルを検索します。検索文字列を参照してください。

文字列

モデル内で、指定した文字列が含まれているすべてのオブジェクトを検索します。検索文字列を参照してください。

検索オプション

[検索オプション] コントロールを使用して、検索範囲と検索文字列の適用方法を指定します。

検索オプション説明
文字列の完全一致

文字列の部分一致を認めません (たとえば、subsubstring と一致しません)。

大文字小文字の区別

文字列を比較する際に大文字/小文字を区別します (たとえば、Gaingain は一致しません)。

正規表現

一致させる文字列を正規表現として比較します。

検索中にプロパティ値を評価

プロパティ値による検索にのみ適用されます。このオプションが有効の場合、モデル エクスプローラーは、各プロパティの値を MATLAB 式として評価し、結果を検索値と比較します。このオプションが無効の場合 (既定値)、モデル エクスプローラーは未評価のプロパティ値を検索値と比較します。

絞り込み検索

最初の検索結果を絞り込むために追加の検索条件を与えて 2 回目の検索を行います。2 回目の検索処理では、元の検索条件と新しい検索条件の両方を満たすオブジェクトが検索されます。

パラメーターの検索方法を示す例については、モデル エクスプローラーを使用した検索を参照してください。

検索文字列

既定の設定では、検索文字列の大文字と小文字は区別されず、正規表現として取り扱われます。

既定の設定では、検索文字列の部分一致が認められます。検索文字列にワイルドカード文字を使用することはできません。たとえば、名前の検索文字列として "*1" と入力した場合、名前が 2 つの文字 "*1" で始まる項目がない限り、一致する検索結果は得られません。out1 の項目が存在しても、検索結果にはその項目は含まれません。

モデル エクスプローラーのコンポーネント

既定の設定では、モデル エクスプローラーには 3 つのペイン ([モデルの階層構造][コンテンツ]、および [ダイアログ]) およびメイン ツール バーが表示されます。[表示]、[ツール バー]、[検索バー] オプションを使用して検索バーを開きます。

コンポーネント目的ドキュメンテーション
メイン ツール バーモデル エクスプローラー コマンドの実行

MATLAB を前面に移動する、または Simulink ライブラリ ブラウザーを開く操作を除き、ほとんどのツール バー ボタンは、モデル エクスプローラーのメニュー項目を使用しても実行可能な操作を実行します。

Simulink Requirements™ がインストールされている場合は、要件リンクに関する追加のツール バー ボタンを使用できます。

検索バー[モデルの階層構造] ペイン内で選択されているノードのコンテキストでの検索の実行検索バーのコントロール
[モデルの階層構造] ペインモデル、チャート、およびワークスペース ノードでの移動と検索モデル エクスプローラー: [モデルの階層構造] ペイン
[コンテンツ] ペインモデルまたはチャート オブジェクトの表示と変更モデル エクスプローラー: [コンテンツ] ペイン
[ダイアログ] ペインオブジェクトのプロパティの詳細の表示と変更モデル エクスプローラー: プロパティ ダイアログ ペイン

モデル、チャートまたはワークスペースへのオブジェクトの追加

モデル エクスプローラーを使用すると、多くの種類のオブジェクトをモデル、チャート、またはワークスペースに追加できます。追加できるオブジェクトのタイプは、[モデルの階層構造] ペインで選択するノードによって異なります。オブジェクトを追加するには、ツール バー ボタンまたは [追加] メニューを使用します。[追加] メニューには、追加できるオブジェクトのタイプがリストされます。

モデルまたはチャートの特定の要素に注目する方法

モデルやチャートで作業しているとき、その一部の要素のみがモデル エクスプローラーに表示されるように制限できます。それにはいくつかの方法があります。次の表は、モデル エクスプローラーに表示されるコンテンツを制御する方法と、そのコンテンツがどのように表示されるかをまとめたものです。

手法使用時ドキュメンテーション

モデルの階層構造のコンテンツの一部または全体の表示

階層モデルの表示範囲の制御

モデルの階層構造のコンテンツの一部または全体の表示

行フィルター オプションの使用

特定の種類のモデル オブジェクト (たとえば信号) を表示または非表示

行フィルター オプションの使用

検索

現在表示されていない可能性のあるオブジェクトを検索

モデル エクスプローラーを使用した検索

コンテンツのフィルター表示

検索文字列に基づいて [コンテンツ] ペイン内の特定オブジェクトに焦点を絞る

コンテンツのフィルター

関心のあるデータのセットが表示されたら、次の手法で表示されるコンテンツを整理できます。

手法使用時ドキュメンテーション

並べ替え

データのプロパティに基づいて昇順または降順にデータを整理

列内容の並べ替え

プロパティ列でグループ化

プロパティの値に基づいてデータを論理的にグループ化

プロパティ列のグループ化手順

列ビューの使用

[モデルの階層構造] ペイン内のノードの種類別に適用できるプロパティ列の名前付きサブセットを表示

モデル エクスプローラーのビューのカスタマイズ

プロパティ表の列の追加、削除、組み直し

プロパティ列をカスタマイズ

モデル エクスプローラーのデータ表示の整理

モデル エクスプローラー: [モデルの階層構造] ペイン

[モデルの階層構造] ペインは、Simulink モデルと Stateflow チャート階層のツリー構造を表示します。[モデルの階層構造] ペインを使用すると、探索する必要のあるモデルおよびチャート階層の特定の部分に移動できます。

[コンテンツ] ペインには [モデルの階層構造] ペイン内で選択されたオブジェクトのコンテンツが表示されます。

Simulink ルート

階層内の最初のノードは Simulink のルートを示します。ルート ノードを展開すると、MATLAB ワークスペース、Simulink モデル、および現在のセッションにある Stateflow チャートを表すノードが表示されます。

ベース ワークスペース

このノードは、MATLAB のワークスペースを表します。MATLAB ワークスペースは、Simulink モデルと Stateflow チャートのベース ワークスペースです。このワークスペースで定義される変数は、開いているすべてのモデルとチャートに表示されます。

ワークスペース変数のエクスポートとインポートは、ワークスペース変数のエクスポートワークスペース変数のインポートを参照してください。

モデル ワークスペース変数およびコンフィギュレーション セットの操作

[モデルの階層構造] ペインでモデル ノードまたはチャート ノードを展開すると、開いているモデルやチャートで該当する、次の要素を表すノードが表示されます。

ノード説明

モデル ワークスペース

モデル ワークスペース変数の操作にモデル エクスプローラーを使用する方法は、次の節を参照してください。

コンフィギュレーション

[コンフィギュレーション] ノードを選択して、モデルのコンフィギュレーション セットとコンフィギュレーション参照を [コンテンツ] ペインで表示します。コンフィギュレーション セットの追加、削除、保存、移動は、コンフィギュレーション セットを管理するを参照してください。

最上位のサブシステム

サブシステムを示すノードを展開すると、その下にサブシステムがある場合は表示されます。

Model ブロック

Model ブロックを展開して参照モデルのコンテンツを表示してください (モデル参照の展開と編集を参照)。

Stateflow チャート

  • Stateflow チャートを示すノードを展開すると、チャートの最上位のステートが表示されます。

  • ステートを示すノードを展開すると、そのサブステートが表示されます。

モデルの階層構造のコンテンツの一部または全体の表示

既定の設定では、モデル エクスプローラーは [モデルの階層構造] ペインで選択されたシステムのオブジェクトを表示します。子 (下位) システムのデータは表示しません。モデル エクスプローラーが現在選択されているシステムの階層全体のオブジェクトを表示するよう、既定の設定をオーバーライドすることもできます。現在のシステムのみの表示と、現在のシステムのシステム階層全体の表示との間で切り替えるには、以下の手法のいずれかを使用します。

  • [表示][現在のシステム以下を表示] を選択します。

  • [コンテンツ] ペインの上部にある [現在のシステム以下を表示] ボタン をクリックします。

[現在のシステム以下を表示] オプションを選択すると、以下のようになります。

  • [モデルの階層構造] ペインでは、現在のシステムとその子 (下位) システムが淡い青色で強調表示されます。

  • [コンテンツ] フィールドのパスの後にテキスト (and below) が表示されます。

  • [コンテンツ] ペインの上部と [表示] メニューにある [現在のシステム以下を表示] ボタンの外観が変化します。

  • [現在のシステム以下を表示] ボタンの上にカーソルを合わせると、表示オブジェクトのスコープがステータス バーに表示されます。

現在のシステムおよびその下位システムのモデルが非常に大きいと、読み込みに時間がかかる場合があります。[現在のシステム以下を表示] ボタンをクリックするか、ツリー階層の別のノードをクリックすると、いつでも読み込み処理を停止できます。

現在のシステム以下を表示する場合は、表示システムの内容をより明確に反映するよう表示を変更することをお勧めします。表示の詳細は、モデル エクスプローラーのビューのカスタマイズを参照してください。

[現在のシステム以下を表示] オプションの設定は、Simulink セッション間で変更されずに保存されます。

リンクされたライブラリ サブシステムおよびマスク サブシステムの表示

既定の設定では、モデル エクスプローラーはリンクされたライブラリ サブシステムまたはマスク サブシステムのコンテンツを [モデルの階層構造] ペインに表示しません。リンクされたライブラリ サブシステムのコンテンツを表示するには、次の方法のいずれかを使用します。

  • [モデルの階層構造] ペインの上部で、[ライブラリ リンクの表示/非表示] ボタン をクリックするか、[マスク サブシステムの表示/非表示] ボタン をクリックします。

  • [表示] メニューから [ライブラリ リンクの表示] または [マスク サブシステムの表示] を選択します。

ライブラリがリンクされたサブシステムおよびマスク サブシステムは、[モデルの階層構造] ペインの構成にかかわらず、[コンテンツ] ペインに表示されます。

メモ

[モデルの階層構造] ペインに表示されていないリンクされたライブラリやマスク サブシステム内の要素は検索されません。

ライブラリにリンクされ、かつマスクされているサブシステムでは、次の表に説明されているように、リンクされたライブラリ サブシステムとマスク サブシステムのオプションの設定方法によって、[モデルの階層構造] ペインにどのサブシステムが表示されるかが左右されます。

設定[モデルの階層構造] ペインに表示されるサブシステム

ライブラリ リンクの表示

マスク サブシステムの非表示

ライブラリにリンクされている、マスクされていないサブシステムのみ

ライブラリ リンクの非表示

マスク サブシステムの表示

ライブラリにリンクされていないマスク サブシステムのみ

ライブラリ リンクの表示

マスク サブシステムの表示

すべてのライブラリにリンクされたサブシステムまたはマスク サブシステム

ブロック線図への移動

エディター ウィンドウでグラフィカル オブジェクト (モデル、サブシステム、チャートなど) を開くには、[モデルの階層構造] ペインでオブジェクトを右クリックします。コンテキスト メニューから [開く] を選択します。

モデル参照の展開と編集

Model ブロックを含むモデルを表示するには、Model ブロックの [モデルの階層構造] ペインのノードを展開します。たとえば、sldemo_mdlref_depgraph モデルには、他のモデルを参照する Model ブロックが含まれています。sldemo_mdlref_depgraph モデルを開き、そのモデルを [モデルの階層構造] ペインで展開すると、モデルに heat2cost をはじめとする複数の Model ブロックが含まれているのがわかります。

Model ブロックが参照しているモデルを表示するには、次の操作を実行します。

  1. 参照モデル ノードを [モデルの階層構造] ペインで右クリックします。

  2. コンテキスト メニューから [モデルを開く] を選択します。

    • 参照モデルが表示されます。

    • [モデルの階層構造] ペインに、Model ブロック ノードを展開できることが示されます。

    • [モデルの階層構造] ペインに、その参照モデルが別の展開可能ノードとして表示されます (読み取りのみ)。

    • [コンテンツ] ペインに、その Model ブロック ノードに対応するオブジェクトが表示されます (読み取りのみ)。

たとえば、heat2cost Model ブロック ノードを右クリックして [モデルを開く] オプションを選択すると、[コンテンツ] ペインに heat2cost Model ブロックに対応するオブジェクトが表示されます。heat2cost ノードは展開できます。

参照モデルのコンテンツは表示できますが、Model ブロック内にあるモデル オブジェクトは編集できません。

参照モデルを編集するには、[モデルの階層構造] ペインで参照モデル ノードを展開してから、参照モデル内のオブジェクトのプロパティにアクセスします。たとえば、sldemo_mdlref_heat2cost ノードを展開します。

参照モデルの詳細は、モデル参照を参照してください。

ワークスペース間でのオブジェクトの切り取り、コピー、貼り付け

ワークスペース オブジェクトは、ワークスペース間で切り取り、コピー、貼り付けができます。

  1. [コンテンツ] ペインで、切り取るかコピーするワークスペース オブジェクトを右クリックします。

  2. コンテキスト メニューから、[切り取り] または [コピー] を選択します。

    • [コンテンツ] ペインで [編集][切り取り] を選択するか、[切り取り] ボタン () をクリックしてワークスペース オブジェクトを切り取ることもできます。

    • [編集][コピー] を選択するか、[コピー] ボタン () をクリックしてワークスペース オブジェクトをコピーすることもできます。

  3. 切り取ったりコピーしたりしたワークスペース オブジェクトを貼り付けるには、[モデルの階層構造] ペインで、オブジェクトの貼り付け先のワークスペースを右クリックし、[貼り付け] を選択します。

    • [編集][貼り付け] を選択するか、[貼り付け] ボタン () をクリックしてオブジェクトを貼り付けることもできます。

    • コピーと貼り付け (またはドラッグ アンド ドロップ) を行うときに、名前の競合の解決を制御することができます。ダイアログ ボックスで、名前が既存の項目と競合している各項目に対して行う動作を選択します。

      • Skip — 競合する項目が同じ値をもっている場合の既定の動作。

      • Replace — 競合する項目が異なる値をもっている場合の既定の動作。

      • Keep both — 両方のコピーを保持。コピーされた項目に指定される名前は、MATLAB ワークスペースで使用される命名規則に従っています。

      コピー元とコピー先が同じである場合は、MATLAB ワークスペースで使用される命名規則に従って名前の競合を解決します。

オブジェクトを選択してドラッグ アンド ドロップ操作を実行することで、切り取り、コピー、貼り付けを行うこともできます。

モデル エクスプローラー: [コンテンツ] ペイン

[コンテンツ] ペインのタブ

[コンテンツ] ペインには、選択したタブに応じて、モデルとチャートに関する情報を含む 2 つの表のどちらかが表示されます。

  • [コンテンツ] タブには、[モデルの階層構造] ペインで選択したノードのオブジェクト プロパティ表が表示されます。

  • [検索結果] タブには、検索結果の表が表示されます (モデル エクスプローラーを使用した検索を参照)。

必要に応じて、[コンテンツ] ペインの列ビューの詳細セクションを開くこともできます。次のグラフィックスは、列ビューの詳細セクションを開いた状態の [コンテンツ] ペインを示しています。

列ビューの詳細セクションを開くには、[コンテンツ] ペインの上部にある [詳細を表示] をクリックします。

列ビューの詳細セクションには列ビューをカスタマイズするためのインターフェイスがあります (既定の設定では非表示)。

オブジェクト プロパティ表セクションにはモデルとチャートのオブジェクト データの表が表示されます (既定の設定では表示)。

[コンテンツ] ペインに表示されるデータ

[コンテンツ] タブと [検索結果] タブのオブジェクト プロパティ表セクションでは、次のように表示されます。

  • 表の列はオブジェクトのプロパティ (NameBlockType など) に対応しています。

    オブジェクト プロパティ表には、最初の 2 つの列 (オブジェクト アイコンと Name プロパティ) が持続的に表示され、右にどれだけスクロールしてもこれらの列は表示され続けます。

  • 表の行はオブジェクト (ブロックや状態など) に対応しています。

[コンテンツ] ペインに表示されるオブジェクトとプロパティは、次の項目に依存します。

  • [コンテンツ] ペインで選択する列のビュー

  • [モデルの階層構造] ペインで選択するノード

  • [モデルの階層構造] ペインで選択するオブジェクトの種類 (たとえば、サブシステムやチャート)

  • 選択する [表示][行フィルター] のオプション

[コンテンツ] ペインに表示するオブジェクトとプロパティの制御方法の詳細は、以下を参照してください。

選択されているノードへのリンク

[コンテンツ] ペインの左上に表示される [コンテンツ] のリンクには、[モデルの階層構造] ペインで選択されているノードの名前が表示されます。[コンテンツ] ペインに表示されるモデル データには、 [現在のシステム以下を表示] オプションの設定が反映されます。この例では、[コンテンツ]vdp (モデル名) と表示されますが、それが現在選択されているノードです。

[コンテンツ] ペインの操作

次の表は [コンテンツ] に表示される内容を制御する主要な作業をまとめたものです。

タスクドキュメンテーション
表示するオブジェクトの種類を制御行フィルター オプションの使用
選択されているオブジェクトの集合内で検索モデル エクスプローラーを使用した検索
ノードの種類に基づいて表示される一連のプロパティを指定モデル エクスプローラーのビューのカスタマイズ
プロパティ列の一意の値に基づいてデータをグループ化プロパティに基づいたグループ化
ビューの管理 (ビューの保存やエクスポートなど)ビューの管理
列の追加、削除、組み換えモデル エクスプローラーのデータ表示の整理
オブジェクトのプロパティ値を編集

オブジェクトのプロパティの編集

オブジェクトのプロパティの編集

オブジェクトのプロパティ ダイアログ ボックスを [モデルの階層構造] ペインで開くには、オブジェクトを右クリックし、コンテキスト メニューから [プロパティ] を選択します。または、オブジェクトをクリックし、[編集] メニューから [プロパティ] を選択します。

[コンテンツ] ペインの変更可能プロパティ (ブロック名など) は、表示されている値を編集することで変更できます。値を編集するには、値を含む行を選択してから値をクリックします。値は編集コントロール (テキスト値の場合は編集フィールド、値の範囲の場合はリストなど) によって置き換えられます。配列または構造体のワークスペース変数には、変数エディターが使用できます。編集コントロールを使用して、選択されているプロパティの値を変更します。

[コンテンツ] ペインの複数のオブジェクトに同じプロパティ値を割り当てるには、オブジェクトを選択し、選択したいずれかのオブジェクトのプロパティを新しい値に変更します。編集コントロールがその値を <edit> で置き換え、一括編集モードであることを示します。モデル エクスプローラーでは、選択した他のオブジェクトにもこの新しいプロパティ値を割り当てます。

プロパティ値は [ダイアログ] ペインを使用して変更することもできます。モデル エクスプローラー: プロパティ ダイアログ ペインを参照してください。

モデル エクスプローラーのデータ表示の整理

オブジェクト プロパティ表と [検索結果] ペインでのプロパティ情報のレイアウトは、次の処理によって操作できます。

  • 列内容の並べ替え

  • プロパティ値によるグループ化

  • プロパティ列の順序の変更

  • プロパティ列の追加

  • プロパティ列の非表示や削除

列内容の並べ替え

列の内容を昇順で並べ替えるには、プロパティ列の見出しをクリックします。列見出しに上向きの三角形が表示されます。順序を昇順から降順に、または降順から昇順に変更するには、列の見出しをもう一度クリックします。

たとえば、Name プロパティに基づいて、プロパティが昇順で表示されている場合 (既定) は、Name 列の見出しをクリックしてオブジェクトを名前の降順で表示します。

既定の設定では、[コンテンツ] ペインは、オブジェクトの名前に基づいて昇順でコンテンツを表示します。プロパティ列に値がないオブジェクトはオブジェクト プロパティ表の最後に表示されます。

メモ

プロパティの値に基づいてグループ化すると、モデル エクスプローラーは列内コンテンツをグループ内で並べ替えます。

プロパティに基づいたグループ化

プロパティ値に基づいたコンテンツの整理-  モデルでの作業で、プロパティ値が同じであるすべてのオブジェクトに焦点を合わせたい場合があります。1 つの方法は、プロパティ列ごとにデータをグループ化することです。

たとえば、f14 モデル内のすべてのブロックを見たい場合を考えてみましょう。次のような検索を実行できます。

検索結果では下位ノードのパス名が途中で途切れて全体が見えなくなっています。

Path プロパティ列に基づいてグループ化することによって、下位ノードのパス全体が表示されます。

グループを折りたたむことによって、モデルの一部に焦点を合わせることもできます。

プロパティ列のグループ化手順-  プロパティに基づいてグループ化するには

  1. オブジェクト プロパティ表で、コンテンツをグループ化する基準となるプロパティの列見出しを右クリックします。

    グループ化はオブジェクト アイコンごとにできます。たとえば、オブジェクトのタイプを表すブロック アイコン () などがあります。最初の列にある空の列見出しを右クリックします。

  2. コンテキスト メニューから、[この列でグループ化] を選択します。

グループ化されたデータの並べ替え-  プロパティの値に基づいてグループ化すると、モデル エクスプローラーは列内コンテンツをグループ内で並べ替えます。

グループ化されたデータの展開と折りたたみ-  既定の設定では、モデル エクスプローラーはグループを展開して表示します。つまり、各グループのすべてのオブジェクトが表示されます。グループは折りたたんだり展開したりできます。

  • グループの内容を折りたたむには、そのグループの折りたたみアイコン (マイナス記号) をクリックします。

  • グループを展開するには、その展開アイコン (プラス記号) をクリックします。

  • すべてのグループを折りたたんだり展開するには、列見出しを右クリックして、[すべてのグループを折りたたむ] メニュー項目を選択する (Shift + C キー) か、[すべてのグループを展開] メニュー項目 (Shift + E キー) を選択します。

グループ列の非表示-  既定の設定では、プロパティ表にはグループ化に使用されるプロパティ列が表示されています。そのプロパティは、各グループの最初の行にも表示されます。

プロパティ表のグループ列を非表示にするには、次のいずれかの方法を使用します。

  • [表示] メニューで、[グループ列を表示] チェック ボックスをオフにします。

  • プロパティ表の列見出しを右クリックし、[グループ列を表示] チェック ボックスをオフにします。

グループ化したデータ設定の持続性-  プロパティに基づくグループ化はビュー定義の一部として保存されます。

[モデルの階層構造] ペインで別のノードを選択すると、新しいノードのコンテンツが同じプロパティによってグループ化されます。ただし、ノードを切り替える前にグループが折りたたまれていたかどうかに関係なく、常にすべてのグループが展開表示されます。

検索結果のグループ化-  グループ化は [検索結果] ペインの整理にも使用できます。[検索結果] ペインに適用するグループ化は、オブジェクト プロパティ表にも同じプロパティが含まれていれば、そこでも適用されます。検索結果がオブジェクト プロパティ表にないプロパティを含んでいて、そのプロパティでグループ化した場合、それまでオブジェクト プロパティ表に適用されていたグループ化は解除されます。

プロパティ列の順序の変更

オブジェクト アイコンと名前列は常に最初-  どのオブジェクト プロパティ表であっても最初の 2 つの列はオブジェクト アイコン列 (空の列見出し付きの列) と Name プロパティ列です。この最初の 2 つの列を非表示にしたり、削除したり、場所を変更することはできません。

プロパティ列の順序を変更する方法-  オブジェクト プロパティ表のプロパティ列の順序を変更するには、次の方法のいずれかを使用します。

  • オブジェクト プロパティ表で、列見出しを選択し、表の新しい場所にドラッグします。

    この方法では、列ビューの詳細セクションを開く必要がなく、左右の短い距離に列を簡単に移動できます。

  • 列ビューの詳細セクションは、1 つ以上のプロパティ列を選択し、リストの右側にある矢印ボタンを使用して、リスト内で上または下方向に移動します。

    この方法では、複数のプロパティ列を一度に移動できますが、選択した列は一度に 1 列のみずつ右または左に移動します。

    ビューの詳細インターフェイスを使用してプロパティ列を移動するには

    1. 列ビューの詳細セクションの右側にある [この順序で列名を表示] リストで、移動する 1 つ以上のプロパティ列を選択します。

    2. [列をビューの左に移動] ボタン または [列をビューの右に移動] ボタン をクリックします。

プロパティ列の追加

プロパティ列をビューに追加するには、次の操作を実行します。

  1. [コンテンツ] ペインの列ビューの詳細セクションがまだ開いていない場合は、[コンテンツ] ペインの上部で [詳細を表示] を選択します。

  2. 列ビューの詳細セクションの左側にあるプロパティ リストで、追加する 1 つ以上のプロパティを選択します。

    • リストには、プロパティ名がアルファベット順で表示されます。列ビューの詳細セクションの [プロパティの検索] 検索ボックスを使用すると、入力したテキスト文字列を含むプロパティを検索できます。検索ボックスの右側にある [左端] リストには、検索範囲を指定できます。

  3. 右側の列名のリストでは、プロパティ列の左側に挿入するプロパティ列を選択します。

  4. [ビューの列としてプロパティを表示] ボタン () をクリックします。

[Path] プロパティ列の追加-  モデル エクスプローラーには、[Path] プロパティ列をビューに追加するためのショートカットが用意されています。[Path] プロパティ列を追加するには、次の手順を実行します。

  1. 挿入する [Path] 列の右側にくる列見出しをオブジェクト プロパティ表内で右クリックします。

  2. コンテキスト メニューから、[パスを挿入] を選択します。

プロパティ列の非表示または削除

2 つの方法のどちらかを選択して、オブジェクト プロパティ表からプロパティ列を隠す (削除する) ことができます。列を隠す場合も、削除する場合も、結果は同じになります。次のことが可能です。

  • 列見出しのコンテキスト メニューを使用して列を隠す。この方法では、列ビューの詳細セクションを開く必要がありません。

  • 列ビューの詳細インターフェイスを使用して列を削除する。この方法では、一度に複数のプロパティを削除できます。

列見出しのコンテキスト メニューを使用した列の非表示

  1. 削除する列の列見出しを右クリックします。

  2. コンテキスト メニューから [隠す] を選択します。

列ビューの詳細インターフェイスを使用した列の削除

  1. [コンテンツ] ペインの列ビューの詳細セクションがまだ開いていない場合は、[コンテンツ] ペインの上部で [詳細を表示] を選択します。

  2. [コンテンツ] ペインの列ビューの詳細セクションにある [この順序で列名を表示] リストで、削除する 1 つ以上のプロパティを選択します。

  3. [列をビューから削除] ボタン () をクリックします。または Delete キーを使用します。

最近隠したか削除した列の挿入-  モデル エクスプローラーは、Simulink セッション中に各ビューに対して隠したか削除した列のリストを保持しています。

最近隠したか削除した列をビューに戻すには、次の手順を実行します。

  1. これから挿入する、最近隠した列の右側にくる列の列見出しを右クリックします。

  2. コンテキスト メニューから、[最近隠された列を挿入] を選択します。

  3. 挿入する列を選択します。

プロパティ列の非表示または削除を参照してください。

存在しないプロパティの印付け

通常、[コンテンツ] ペインに表示されるプロパティの中には、すべてのオブジェクトに適用されない (つまり、値が設定されていない) ものがあります。既定の設定では、モデル エクスプローラーは値をもたないプロパティをマーク付けするためにダッシュ (–) を表示します。

モデル エクスプローラーで、値をもたないプロパティ セルに (既定のダッシュの代わりに) 空白が表示されるようにするには、[表示] [存在しないプロパティを "-" として表示] オプションをオフにします。[コンテンツ] ペインは次の図のようになります。

モデル エクスプローラーのフィルター オブジェクト

[コンテンツ] ペインに表示されるオブジェクトの集合を制御するために使用される 2 つの手法は以下のとおりです。

  • 行フィルター オプションの使用

  • コンテンツのフィルター

他の手法の要約は、モデルまたはチャートの特定の要素に注目する方法を参照してください。

行フィルター オプションの使用

[コンテンツ] ペインに表示されるオブジェクトの種類はフィルター処理できます。

  1. [行フィルター] オプション メニューを開きます。モデル エクスプローラーで、[コンテンツ] ペインの右上隅で [行フィルター] ボタンをクリックします。

    [行フィルター] メニューを開く代替方法は、[表示][行フィルター] を選択することです。

    既定の設定では、[コンテンツ] ペインには、選択されているノードに対して次の種類のオブジェクトが表示されます。

    • ブロック

    • Stateflow イベント

    • Stateflow データ

  2. [コンテンツ] ペインに表示しないオブジェクトの種類はオフにするか、オフになっているオプションを有効にして、より多くの種類のオブジェクトを表示します。たとえば、[コンテンツ] ペインに Stateflow イベントが表示されないようにするには、[イベント] をオフにします。

オブジェクト数-  [コンテンツ] ペインの右上の部分には、[コンテンツ] ペインに表示されているオブジェクトの数を示す、オブジェクト カウンターが含まれています。

[行フィルター] オプションを使用してオブジェクトをフィルター処理すると、オブジェクト数のインジケーターには [コンテンツ] ペインにすべてのモデルおよびチャート オブジェクトのサブセットが表示されていることが反映されます。

現在のオブジェクト数の説明を表示するには、オブジェクト数のリンク (12/25 オブジェクト など) をクリックします。

コンテンツのフィルター

[コンテンツ] ペインに現在表示されているオブジェクトの表示を絞り込むには、[コンテンツ] ペイン上部にある [コンテンツのフィルター] テキスト ボックスを使ってオブジェクトのサブセットをフィルター表示するための検索文字列を指定します。

[コンテンツのフィルター] テキスト ボックスの使用によって、オブジェクト集合内の特定のオブジェクトを、オブジェクト名、プロパティ値、関心プロパティなどを手がかりにして見つけ出すことができます。たとえば、[コンテンツのフィルター] テキスト ボックスに「fuel」と入力すると、モデル エクスプローラーは上の図のような結果を表示します。

フィルター文字列の指定-  [コンテンツのフィルター] テキスト ボックスにテキストを入力すると、モデル エクスプローラーは動的検索を行い、入力したテキストを反映した結果を表示します。

入力するテキスト文字列は次の節に説明されているガイドラインに従った形式でなければなりません。

大文字小文字の区別 — 既定の設定では、モデル エクスプローラーのフィルター処理に大文字小文字の区別は適用されません。

テキスト文字列の大文字小文字の区別を有効にするにはテキスト文字列を引用符で囲みます。

プロパティとプロパティ値の指定 — 特定のプロパティをもつオブジェクトにフィルター処理が適用されるように制限するには、プロパティ名を指定し、それに続けてコロンを指定します。[コンテンツ] ペインに、そのプロパティをもつオブジェクトが表示されます。

特定の値の特定のプロパティをもつオブジェクトにフィルターを適用するには、プロパティ名を指定し、それに続けてコロン (:) と値を指定します。たとえば、OutDataTypeStr プロパティの値に Inherit が含まれるオブジェクトのみが表示されるように内容にフィルターを適用するには、「OutDataTypeStr: Inherit」と入力します (または、この文字列全体を引用符で囲うと大文字小文字の区別を指定できます)。

ワイルドカードおよび MATLAB 式はサポートされない — モデル エクスプローラーはアスタリスク (*) などのワイルドカード文字を特別な意味をもつ文字として解釈しません。たとえば、fuel*[コンテンツのフィルター] テキスト ボックスに入力した場合、fuel という文字列を含むオブジェクトがいくつかあっても、結果には何も表示されません。

同様に、[コンテンツのフィルター] テキスト ボックスで MATLAB 式を指定すると、入力文字列は文字通りに解釈され、MATLAB 式としては解釈されません。

フィルター処理されたコンテンツのクリア-  オブジェクト プロパティ表をフィルター処理する前の状態に戻すには、[コンテンツのフィルター] テキスト ボックス内の [X] をクリックします。

フィルターによるグループ化の解除-  グループ化を適用した列がある場合、コンテンツをフィルター処理すると、モデル エクスプローラーはそのグループ化を保持しません。

モデル エクスプローラー: プロパティ ダイアログ ペイン

[ダイアログ] ペインを使用して、[モデルの階層構造] ペインまたは [コンテンツ] ペインで選択したオブジェクトのプロパティを表示または変更します。

[ダイアログ] ペインの表示と非表示

既定の設定では、[ダイアログ] ペインはモデル エクスプローラーの [コンテンツ] ペインの右側に表示されます。[ダイアログ] ペインの表示と非表示を切り替えるには、次の方法のどちらかを使用します。

  • [表示] メニューから、[ダイアログ ペインを表示] を選択します。

  • メイン ツール バーの [ダイアログの表示] ボタン () をクリックします。

[ダイアログ] ペインのプロパティの編集

[ダイアログ] ペインを使用してプロパティ値を編集するには、次の手順を実行します。

  1. [コンテンツ] ペインで、オブジェクト (ブロックや信号など) を選択します。[ダイアログ] ペインに、選択したオブジェクトのプロパティが表示されます。

  2. [ダイアログ] ペインのプロパティ (Outport ブロックの端子番号など) を変更します。

  3. [適用] をクリックして変更を承認するか、[元に戻す] をクリックして元の値に戻します。

既定の設定では、変更が適用されていないダイアログ ボックスの外側をクリックすると、[変更の適用] ダイアログ ボックスが表示されます。

[適用] をクリックして変更を承認するか、[無視] をクリックして元の設定に戻ります。

[変更の適用] ダイアログ ボックスを非表示にするには、次の手順を実行します。

  1. ダイアログ ボックスで、[今後、尋ねることなく適用されるか無視されます (いずれか選択した方)] チェック ボックスをオンにします。

  2. 警告なしに Simulink に変更を適用させるには、[適用] をクリックします。警告なしに Simulink に変更を無視させるには、[無視] をクリックします。

[変更の適用] ダイアログ ボックスを再表示するには、[ツール] メニューから [変更が適用されていない場合にダイアログを表示] を選択します。

[引数] チェック ボックス

モデル ワークスペースで MATLAB の数値変数または Simulink.Parameter オブジェクトを選択すると、[ダイアログ] ペインに [引数] チェック ボックスが表示されます。このチェック ボックスをオンにすると、その変数またはオブジェクトがモデル引数として設定されます。再利用可能な参照モデルのインスタンスのパラメーター化を参照してください。

関連するトピック