ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

sptool

対話型デジタル信号処理ツールを起動

構文

sptool
s = sptool('Signals')
f = sptool('Filters')
s = sptool('Spectra')
[s,ind] = sptool(___)
s = sptool(___,0)
struc = sptool('create',paramlist)
sptool('load',struc)
struc = sptool('load',paramlist)

説明

メモ

SPTool は将来のリリースで削除される予定です。

  • 信号とスペクトルの解析には、代わりに信号アナライザー アプリを使用してください。

  • フィルターの設計には、代わりにフィルター デザイナー アプリを使用してください。

  • フィルターの可視化には、代わりに fvtool を使用してください。

コマンド sptool は SPTool を起動します。これはツールのセットで、信号ブラウザー、フィルターの設計と解析ツール、FVTool、スペクトル ビューアーが組み込まれています。これらのツールから、ツールボックスに用意されている多くの信号、フィルター、スペクトル解析の関数にアクセスできます。SPTool スイートはコマンド ラインに sptool と入力して開きます。

SPTool では次が可能です。

  • 信号ブラウザーを使用した、[信号] リスト ボックス内の信号の解析

  • フィルターの設計と解析ツール (極-零点エディターも含む) を使用した、フィルターの設計や編集

  • FVTool を使用した、[フィルター] リストボックス内にあるフィルターのフィルター応答の解析

  • [信号] リスト ボックス内の信号に対する、[フィルター] リスト ボックス内のフィルターの適用

  • スペクトル ビューアーを使用した、信号スペクトルの作成と解析

  • 信号ブラウザー、フィルターの設計と解析ツールおよびスペクトル ビューアーの印刷

統合された 4 つの信号処理ツールはすべて SPTool から起動できます。

信号ブラウザー

信号ブラウザー (以降、スコープとも呼ぶ) では、1 つまたは複数の信号を時間領域で表示、測定、解析できます。信号ブラウザーを起動するには、SPTool の [信号] リスト ボックスで [表示] ボタンをクリックします。

信号ブラウザーに関する詳細は、次の節を参照してください。

複数の信号の表示

複数の信号入力

[信号] リスト ボックスで複数の信号を選択し、同じ表示領域または個別の表示領域に複数の信号を表示します。既定では、信号は同じ表示領域上に異なる色の線で表示されます。信号は、異なる次元、サンプルレートおよびデータ型をもつことができます。各信号の値は、実数または複素数のどちらでもかまいません。

複数の信号の色

既定では、信号ブラウザーの座標軸の背景は白で、MATLAB® 関数 plot と同様の方法で各チャネルのラインの色を選択します。信号ブラウザーでは入力信号の実数部と虚数部をそれぞれ 1 つのチャネルと考え、各チャネルに次の順序でラインの色を割り当てます。

  1. 濃い緑

  2. シアン

  3. 濃い黄色

7 チャネルより多い場合、スコープでは残りのチャネルに、ラインの色をこの順番で繰り返し割り当てます。たとえば、4 つの複素数値の入力信号を選択した場合、次の凡例が表示領域に表示されます。

すべての入力信号が実数値の場合、信号ブラウザーはそれらの虚数部に関連付けられていたラインの色を省略します。たとえば、4 つの実数値の入力信号を選択した場合、次の凡例が表示領域に表示されます。

ラインの色を手作業で変更するには、[表示][スタイル] を選択して [スタイル] ダイアログ ボックスを開きます。[ラインのプロパティ] の隣で、色を変更する信号の名前を選択します。次に、[ライン] の隣の [ラインの色] ボタン () をクリックし、パレットから色を選択します。座標軸の背景色を変更するには、[Axes の背景色] ボタン () をクリックし、パレットから色を選択します。

複数の表示領域の使用

複数のデータ チャネルをウィンドウの別々の表示領域に表示できます。ツール バーで、[表示][レイアウト] を選択するか、[レイアウト] ボタン () を選択します。

ウィンドウを複数の表示領域に分けて並べて表示することができます。たとえば、ツールに 3 つの入力がある場合、3 つの個別の表示領域に信号を表示できます。レイアウト グリッドには 4 行 4 列のグリッドが表示されていますが、レイアウト グリッド内をクリックしてドラッグすることで最大 16 行 16 列まで選択できます。

[レイアウト] オプションを使用してウィンドウを複数の表示領域に分けて並べて表示する場合、青で強調表示された表示領域は "アクティブな表示領域" と呼ばれます。ダイアログ ボックスはアクティブな表示領域を参照します。

信号の表示

信号ブラウザーは、時間範囲に関して [信号] リスト ボックスで選択したすべての入力信号の中の最長の時間の長さを使用します。現在の表示領域に対応する時間の配列をやりとりするために、スコープ ウィンドウは 最小時間軸限界、時間単位および最大時間軸限界のインジケーターを使用します。次の図では、信号ブラウザー ウィンドウのこれらの部分について明らかにしています。

  • 最小時間軸限界 — 信号ブラウザーは time 軸の範囲最小値を 0 に設定します。

  • 最大時間軸限界 — 信号ブラウザーは time 軸の範囲最大値を最長の入力信号の最終タイム ステップに設定します。

  • 時間単位 — time 軸の記述に使用する単位です。信号ブラウザーは、[ビジュアル: 時間領域オプション] ダイアログ ボックスの [メイン] タブにある [時間単位] パラメーターの値を使用して時間単位を設定します。既定では、このパラメーターは [基準 (時間範囲に基づく)] に設定され、マイクロ秒、ミリ秒、分、日などの計量単位で表示されます。測定単位を [秒] に変更して time 軸の値を常に秒単位で表示するようにできます。これを [なし] に変更すると、time 軸に関する測定基準の単位が非表示になります。このパラメーターを [なし] に設定すると、信号ブラウザーの time 軸には Time という単語しか表示されません。

    time 軸の Time という単語と値の両方を非表示にするには、[時間軸ラベルの表示] パラメーターを [なし] に設定します。time 軸の Time という単語と値の両方を、各列の一番下を除くすべての表示領域で非表示にするには、このパラメーターを [下部表示のみ] に設定します。この動作は、x 軸上に値は表示するけれどもラベルは表示しない Simulink® Scope ブロックの動作とは異なります。

信号名と凡例のテキスト

信号ブラウザーは、凡例に表示されるテキストとして SPTool の信号名を使用します。[信号] リストボックスで選択した信号の名前を変更する場合、信号ブラウザー内の対応する凡例エントリも変化します。選択した信号の名前を変更するには、SPTool のメニューから [編集][名前] を選択します。信号ブラウザーは凡例を自動的に更新し、入力された新しい信号名を反映します。同様に、信号ブラウザーの任意の凡例エントリを変更すると、SPTool が [信号] リスト ボックス内の対応する信号名を更新します。

座標軸の最大化

最大化された座標軸モードで信号ブラウザーを表示するかどうかを指定できます。このモードでは、座標軸は表示領域全体に広がるように拡張されます。各表示領域にはタイトルや座標軸のラベルを表示するスペースはありません。最小および最大 time 軸の範囲は、表示領域の左右両端に表示されます。座標軸の目盛りの値は、軸の上にグリッド線として表示されます。次の図では、最大化された座標軸モードで 3 つの表示領域がどのように信号ブラウザー ウィンドウに表示されるかを明らかにしています。

このモードを有効または無効にするには、信号ブラウザー メニューで [表示][プロパティ] を選択し、[ビジュアル: 時間領域オプション] ダイアログ ボックスを開きます。[メイン] ペインで、[軸の最大化] パラメーターを次のいずれかのオプションに設定できます。

  • [自動] — このモードでは、各表示領域に対して [タイトル] および [Y 軸ラベル] パラメーターが空の場合に限り、軸は表示領域全体に広がるように最大化されます。いずれかの表示領域でこれらのパラメーターのどちらかに値を入力すると、軸は最大化されません。

  • [オン] — このモードでは、すべての表示で座標軸が最大化されます。[タイトル] および [Y 軸ラベル] パラメーターに入力された値は表示されません。

  • [オフ] — このモードでは、いずれの軸も最大化されません。

詳細は、ビジュアル — 時間領域オプションの節を参照してください。

ツール バー

信号ブラウザー ツール バーには以下のボタンがあります。

印刷ボタン

ボタンメニューの位置ショートカット キー説明

[ファイル][印刷]Ctrl+P

現在のスコープ ウィンドウを印刷します。現在のスコープ ウィンドウをプリンターに送信するのではなく、Figure に出力するには、[ファイル][Figure に出力] を選択します。

ズーム ボタンと座標軸の制御ボタン

ボタンメニューの位置ショートカット キー説明

[ツール]
[ズームイン]

N/A

このツールを有効にすると、スコープ ウィンドウでズームインできます。これを行うには、関心のある領域の中心部をクリックするか、カーソルをクリックしてドラッグし、スコープ ウィンドウ内の関心のある長方形の領域を描きます。

[ツール]
[X 軸ズーム]

N/A

[X 軸ズーム] ボタンには、[ズームイン] アイコンの下のメニューからアクセスします。このツールを有効にすると、x 軸にズームインできます。操作は、スコープ ウィンドウ内をクリックするか、カーソルをクリックして対象領域を x 軸に沿ってドラッグします。

[ツール]
[Y 軸ズーム]

N/A

[Y 軸ズーム] ボタンには、[ズームイン] アイコンの下のメニューからアクセスします。このツールを有効にすると、y 軸にズームインできます。操作は、スコープ ウィンドウ内をクリックするか、カーソルをクリックして対象領域を y 軸に沿ってドラッグします。

[ツール]
[移動]

N/A

[移動] ボタンには、[ズームイン] アイコンの下のメニューからアクセスします。このツールを有効にすると、スコープ ウィンドウで表示を移動させられます。移動させるには、対象領域の中央をクリックしてカーソルを上下左右にドラッグして、表示領域の位置を動かします。

[ツール]
[Y 軸の範囲をスケール]
Ctrl+A

アクティブな スコープ ウィンドウで座標軸をスケーリングするには、このボタンをクリックします。

または、[ツール] メニューから次のいずれかのオプションを選択することで、座標軸の自動スケーリングを有効にできます。

  • [座標軸の範囲を自動的にスケール] — このオプションを選択すると、シミュレーション中に必要に応じてスコープが軸をスケーリングします。

  • [10 回の更新後に座標軸の範囲をスケール] — このオプションを選択すると、スコープは 10 回の更新後に軸をスケーリングします。シミュレーション中は、スコープによる軸の再スケーリングは行われません。

  • [座標軸の範囲を停止時にスケール] — このオプションを選択すると、シミュレーションが停止するたびにスコープが軸をスケーリングします。

[ツール]
[X 軸の範囲をスケール]
N/A

[X 軸の範囲をスケール] ボタンには、現在の [Axis Limits] アイコンの下のメニューからアクセスします。アクティブなスコープ ウィンドウで座標軸を X 方向にスケーリングするには、このボタンをクリックします。

または、[ツール] メニューから次のいずれかのオプションを選択することで、座標軸の自動スケーリングを有効にできます。

  • [座標軸の範囲を自動的にスケール] — このオプションを選択すると、シミュレーション中に必要に応じてスコープが軸をスケーリングします。

  • [10 回の更新後に座標軸の範囲をスケール] — このオプションを選択すると、スコープは 10 回の更新後に軸をスケーリングします。シミュレーション中は、スコープによる軸の再スケーリングは行われません。

  • [座標軸の範囲を停止時にスケール] — このオプションを選択すると、シミュレーションが停止するたびにスコープが軸をスケーリングします。

[ツール]
[X 軸と Y 軸の範囲をスケール]
N/A

[X 軸の範囲をスケール] ボタンには、現在の [Axis Limits] アイコンの下のメニューからアクセスします。アクティブなスコープ ウィンドウで座標軸を X および Y の両方向にスケーリングするには、このボタンをクリックします。

または、[ツール] メニューから次のいずれかのオプションを選択することで、座標軸の自動スケーリングを有効にできます。

  • [座標軸の範囲を自動的にスケール] — このオプションを選択すると、シミュレーション中に必要に応じてスコープが軸をスケーリングします。

  • [10 回の更新後に座標軸の範囲をスケール] — このオプションを選択すると、スコープは 10 回の更新後に軸をスケーリングします。シミュレーション中は、スコープによる軸の再スケーリングは行われません。

  • [座標軸の範囲を停止時にスケール] — このオプションを選択すると、シミュレーションが停止するたびにスコープが軸をスケーリングします。

測定ボタン

[ツール]
[測定値]

[カーソルの測定]

N/A

[カーソルの測定] パネルを開いたり閉じたりします。このパネルは、すべての表示領域にスクリーン カーソルを配置します。

詳細は、[カーソルの測定] パネルの節を参照してください。

[ツール]
[測定値]

[信号の統計]

N/A

[信号の統計] パネルを開いたり閉じたりします。このパネルには、選択した信号の最大値、最小値、ピーク間の差、平均値、中央値、RMS 値および最大値と最小値の発生時刻が表示されます。

詳細は、信号の統計パネルの節を参照してください。

[ツール]
[測定値]

[バイレベル測定]

N/A

[バイレベル測定] パネルを開いたり閉じたりします。このパネルには、選択した信号の遷移、オーバーシュートまたはアンダーシュート、およびサイクルに関する情報が表示されます。

詳細は、バイレベル測定パネルの節を参照してください。

[ツール]
[測定値]

[ピークの検出]

N/A

[ピークの検出] パネルを開いたり閉じたりします。このパネルには、最大値とそれらが発生した時刻が表示され、ピークしきい値、ピークの最大数、ピーク偏位の設定を変更できます。

詳細は、ピークの検出パネルの節を参照してください。

その他のボタン

[ツール][選択した信号を再生]

N/A

音声信号を再生します。関数 soundsc を使用して信号を再生します。

[表示][すべての凡例を表示]

N/A

各表示領域の信号名に、各ライン スタイルに一致する凡例を表示します。

[表示][レイアウト]

N/A

信号ブラウザーで表示領域のレイアウトを調整します。この機能を使用すると、複数 (最大 4 行 4 列のグリッド) の個別の表示領域にスクリーンを並べて表示できます。SPTool で複数の入力信号を選択する場合に、複数の表示領域があると便利です。既定の表示領域は 1 行および 1 列です。

このツール バーを信号ブラウザー ウィンドウに表示するかどうかを制御できます。信号ブラウザーのメニューから、[表示][ツール バー] を選択します。

測定値パネル

[測定値] パネルとは、信号ブラウザーの右側に表示される 5 つのパネルです。これらのパネルには、[トレース選択][カーソルの測定][信号の統計][バイレベル測定] および [ピークの検出] とラベルが付いています。

測定値パネルのボタン

それぞれの [測定値] パネルには、現在のパネルの外観を変更できるようにする以下のボタンが含まれています。

ボタン説明

現在のパネルを上部に移動します。複数のパネルを表示している場合、このアクションは、他のすべてのパネルの上に現在のパネルを移動します。

現在のパネルを折りたたみます。最初にパネルを有効にすると、既定ではそのペインが 1 つまたは複数表示されます。スペースを節約するためにペインをすべて非表示にするには、このボタンをクリックします。このボタンは、クリック後は展開ボタン になります。

現在のパネルを展開します。このボタンは、折りたたみボタンをクリックして現在のパネルのペインを非表示にすると表示されます。現在のパネルにペインを表示し、再度測定値を表示するには、このボタンをクリックします。このボタンをクリックすると、それが再度折りたたみボタン になります。

現在のパネルをアンドックします。このボタンは、現在のパネルを別のウィンドウに移動し、画面上の任意の場所に移動することができます。このボタンは、クリック後は新しいウィンドウの中でドック ボタン になります。

現在のパネルをドッキングします。このボタンは、アンドック ボタンをクリックした場合にのみ表示されます。このボタンをクリックすると、現在のパネルがスコープ ウィンドウの右側に元のとおり配置されます。このボタンをクリックすると、それが再度アンドック ボタン になります。

現在のパネルを閉じます。このボタンを使用すると、現在のパネルをスコープ ウィンドウの右側から削除できます。

パネルによっては、測定値が複数のペインにカテゴリーごとに分割されています。ペインの展開ボタン をクリックすると、現在のパネル内で非表示になっている各ペインが表示されます。ペインの折りたたみボタン をクリックすると、現在のパネル内で表示されている各ペインが非表示になります。

トレース選択パネル

スコープを使用して複数の信号を表示する際、複数の信号が表示された状態で他の [測定値] パネルのいずれかをクリックすると、[トレース選択] パネルが表示されます。[測定値] パネルには、このパネルで選択された信号に関する情報のみが表示されます。時間領域の測定値を表示する信号名を選択します。下の図を参照してください。

[トレース選択] パネルは表示/非表示が選択できます。スコープのメニューから、[ツール][測定値][トレース選択] を選択します。

[カーソルの測定] パネル

[カーソルの測定] パネルは、スクリーン カーソルを表示します。パネルには、信号を測定するためのカーソルが 2 種類あります。波形カーソルは、信号に沿って移動する垂直方向のカーソルです。スクリーン カーソルは、表示の任意の場所に配置できる垂直および水平の両方向のカーソルです。

メモ

信号のデータ点が複数の値をもつ場合、その点におけるカーソルの測定は定義されず、カーソルの値は表示されません。

スコープのメニューから、[ツール][測定値][カーソルの測定] を選択します。または、スコープのツール バーで、[カーソルの測定] ボタンをクリックします。

[設定] ペインを使用して測定値の計算に使用するスクリーン カーソルの種類を変更できます。複数の信号が表示されているときは、トレースごとに個別にカーソルを割り当てることができます。

  • スクリーン カーソル — スクリーン カーソルを表示します。

  • 水平方向 — 水平方向のスクリーン カーソルを表示します。

  • 垂直方向 — 垂直方向のスクリーン カーソルを表示します。

  • 波形カーソル — 入力信号に付加されるカーソルを表示します。

  • カーソル間隔のロック — 2 つのカーソル間の周波数の差を固定します。

  • データにスナップ — 信号のデータ点にカーソルを置きます。

マウスまたは左右の方向キーで垂直カーソルまたは波形カーソルを、上下の方向キーで水平カーソルを動かすことができます。

[測定値] ペインには、時間と値の測定値が表示されます。

  • [1 |] — カーソル番号 1 の時間または値、あるいはその両方の表示または修正ができます。

  • [2 :] — カーソル番号 2 の時間または値、あるいはその両方の表示または修正ができます。

  • [Δt] — カーソル番号 1 と 2 との間の時差の絶対値を表示します。

  • [ΔV] — カーソル番号 1 と 2 との間の信号振幅の差の絶対値を表示します。

  • [1/Δt] — カーソル番号 1 と 2 との間の時差の絶対値の逆数 (比率) を表示します。

  • [ΔV/Δt] — カーソル間の時差の絶対値に対する、カーソル間の信号振幅の差の絶対値の比率 (範囲) を表示します。

信号の統計パネル

メモ

[信号の統計] パネルを使用するには、DSP System Toolbox™ または Simscape™ のライセンスが必要です。

[信号の統計] パネルには、選択した信号の最大値、最小値、ピーク間の差、平均値、中央値および RMS 値が表示されます。また、最大値および最小値が発生する x 軸のインデックスも表示されます。スコープのメニューから、[ツール][測定][信号の統計] を選択します。別の方法として、スコープのツール バーで、[信号の統計] ボタンをクリックします。

表示される統計は次になります。

  • [最大値] — 入力信号の表示部分内の最大値。この計測で使用するアルゴリズムの詳細は、MATLAB 関数 max のリファレンスを参照してください。

  • [最小値] — 入力信号の表示部分内の最小値。この計測で使用するアルゴリズムの詳細は、MATLAB 関数 min のリファレンスを参照してください。

  • [ピーク ツー ピーク] — 入力信号の表示部分内の最大値と最小値の差。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox™ 関数 peak2peak のリファレンスを参照してください。

  • [平均] — 入力信号の表示部分内のすべての値の平均値。この計測で使用するアルゴリズムの詳細は、MATLAB 関数 mean のリファレンスを参照してください。

  • [中央値] — 入力信号の表示部分内の中央値。この計測で使用するアルゴリズムの詳細は、MATLAB 関数 median のリファレンスを参照してください。

  • [RMS] — 入力信号の表示部分内の最大値と最小値の差が表示されます。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 rms のリファレンスを参照してください。

スコープのズーム オプションを使用すると、信号の統計の測定は表示領域に表示される時間範囲に自動的に調整されます。たとえば、1 つのパルスにズームインして、[信号の統計] パネルにその特定のパルスのみに関する情報を表示させることができます。

信号の統計の測定は、任意の入力信号単位について有効です。milli- を表す m など、各測定の対応値の後の文字は、適切な国際単位系 (SI) の接頭辞を表します。たとえば、入力信号がボルト単位で測定された場合、測定値の横にある m は値がミリボルト単位であることを示します。

バイレベル測定パネル

メモ

[バイレベル測定] パネルを使用するには、DSP System Toolbox または Simscape のライセンスが必要です。

[バイレベル測定] パネルには、選択した信号の遷移、オーバーシュート、アンダーシュートおよびサイクルに関する情報が表示されます。[バイレベル測定] パネルは表示/非表示が選択できます。スコープのメニューから、[ツール][測定][バイレベル測定] を選択します。または、スコープのツール バーで、[バイレベル測定] ボタンを選択することもできます。

スコープのズーム オプションを使用すると、バイレベル測定は表示領域に表示される時間範囲に自動的に調整されます。たとえば、1 つの立ち上がりエッジにズームインし、[バイレベル測定] パネルにその特定の立ち上がりエッジのみに関する情報を表示させます。この機能は [高] および [低] の測定には適用されません。

[バイレベル測定] パネルは、4 つのペインに分割されており、それぞれ[設定][遷移][オーバーシュート/アンダーシュート] および [サイクル] というラベルが付けられています。各ペインを展開して使用できるオプションを確認できます。

 バイレベル測定のプロット

メモ

パルスの最後のエッジが、プロットの最後の [シーク整定] 時間内にない場合に、[Overshoots/Undershoots] ペインを開くと、利用可能なエッジの数が 1 つ減少する場合があります。エッジ数の減少により、[遷移] ペインの [エッジ][立ち下がり時間] および [スルー レート] の値が変わります。

[設定] ペインでは、遷移、オーバーシュート、アンダーシュートおよびサイクルに関わるさまざまな測定値を計算するのに使用されるプロパティを変更できます。次の図に示すように、High 状態レベル、Low 状態レベル、状態レベルの許容誤差、上位基準レベル、中央基準レベルおよび下位基準レベルを変更できます。

  • [自動状態レベル] — このチェック ボックスが選択されていると、[バイレベル測定] パネルは、2 値波形の High 状態レベルと Low 状態レベルを自動検出します。このオプションに使用されるアルゴリズムについての詳細は、Signal Processing Toolbox 関数 statelevels のリファレンスを参照してください。このチェック ボックスがオフになっている場合は、High 状態レベルと Low 状態レベルの値を直接入力できます。

    • [高] — 正極性または High 状態レベルの値を手動で指定。

    • [低] — 負極性または Low 状態レベルの値を手動で指定。

  • [状態レベル許容誤差] — 各遷移の初期レベルと最終レベルが間に収まらなければならない、それぞれの状態レベルの許容誤差です。この値は、High と Low の状態レベル間の差をパーセント比として表します。

  • [上位基準レベル] — 立ち上がり時間の測定の終了または立ち下がり時間の測定開始の計算に使用されます。この値は、High と Low の状態レベル間の差をパーセント比として表します。

  • [中央基準レベル] — 遷移発生時間の決定に使用されます。この値は、High と Low の状態レベル間の差をパーセント比として表します。中央基準レベルは水平線で表示され、それに対応する中央基準レベル瞬時は垂直線で表示されます。

  • [下位基準レベル] — 立ち下がり時間の測定の終了または立ち上がり時間の測定の開始を計算するのに使用されます。この値は、High と Low の状態レベル間の差をパーセント比として表します。

  • [シーク整定] — 各遷移の発生時に、有効な整定時間を計算するのに使用される中央基準レベル瞬時後の期間。この値は、関数 settlingtime 実行時に設定可能な入力パラメーター D と等価です。整定時間は [オーバーシュート/アンダーシュート] ペインに表示されます。

[遷移] ペインには、High と Low という 2 つの可能な状態レベル値の間で変化する入力信号に対応して求められる、測定値が表示されます。遷移の測定値では、入力信号の振幅の単位はボルトとしています。遷移の測定値を有効するには、すべての入力信号をボルト単位に変換します。

2 値波形での立ち上がり遷移、または "立ち上がりエッジ" は、Low 状態レベルから High 状態レベルへの遷移です。立ち上がり遷移は、ゼロより大きい勾配値をもっています。テキスト ラベルの横にプラス記号 (+) がある場合はいつでも、この記号は、立ち上がりエッジに関連する測定、つまり Low 状態レベルから High 状態レベルへの遷移を指します。

2 値波形での立ち下がり遷移、または "立ち下がりエッジ" は、High 状態レベルから Low 状態レベルへの遷移です。立ち下がり遷移は、ゼロより小さい勾配値をもっています。テキスト ラベルの横にマイナス記号 (-) がある場合はいつでも、この記号は、立ち下がりエッジに関連する測定、つまり High 状態レベルから Low 状態レベルへの遷移を指します。

  • [高][時間範囲] パラメーターの期間にわたる、入力信号の高振幅の状態レベルです。[時間範囲] は、[ビジュアル - 時間領域プロパティ] ダイアログ ボックスの [メイン] タブまたは [時間] タブで設定できます。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 statelevels のリファレンスを参照してください。

  • [低][時間範囲] パラメーターの期間にわたる、入力信号の低振幅の状態レベルです。[時間範囲] は、[ビジュアル - 時間領域プロパティ] ダイアログ ボックスの [メイン] タブまたは [時間] タブで設定できます。[時間範囲] が表示されるタブは、MATLAB System object™ と Simulink ブロックのどちらからこのスコープを起動したかによって異なります。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 statelevels のリファレンスを参照してください。

  • [振幅] — High 状態レベルと Low 状態レベル間の振幅の差。

  • [+ エッジ] — 入力信号の表示部分内でカウントされた正極性または立ち上がりのエッジの合計数。

  • [+ 立ち上がり時間] — 各立ち上がりエッジが下位基準レベルから上位基準レベルに達するのにかかる平均時間。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 risetime のリファレンスを参照してください。

  • [+ スルー レート] — 入力信号の表示部分内の上位パーセント基準レベルと下位パーセント基準レベル内の各立ち上がりエッジ遷移ラインの平均勾配。スルー レートが計算された領域が灰色で表示されます。

    この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 slewrate のリファレンスを参照してください。

  • [- エッジ] — 入力信号の表示部分内でカウントされた負極性または立ち下がりエッジの合計数。

  • [- 立ち上がり時間] — 各立ち上がりエッジが下位基準レベルから上位基準レベルに達するのにかかる平均時間。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 falltime のリファレンスを参照してください。

  • [– スルー レート] — 入力信号の表示部分内の上位パーセント基準レベルと下位パーセント基準レベル内の各立ち下がりエッジ遷移ラインの平均勾配。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 slewrate のリファレンスを参照してください。

[オーバーシュート/アンダーシュート] ペインには、入力信号の歪みと減衰を伴う、計算された測定値が表示されます。"オーバーシュート" および "アンダーシュート" は、信号がその最終的な定常値をそれぞれ上回るおよび下回る量を表します。"プレシュート" は、信号が初期定常値からの変化としての遷移を行う前の量を表します。次の図は、立ち上がりエッジ遷移のプレシュート、オーバーシュートおよびアンダーシュートを表します。

 オーバーシュート/アンダーシュートのプロット

  • + プレシュート — 各立ち上がり遷移の直前の領域にある平均最低逸脱。

  • + オーバーシュート — 各立ち上がり遷移の直後の領域にある平均最高逸脱。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 overshoot のリファレンスを参照してください。

  • + アンダーシュート — 各立ち上がり遷移の直後の領域にある平均最低逸脱。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 undershoot のリファレンスを参照してください。

  • + 整定時間 — 各立ち上がりエッジが High 状態レベルの許容誤差内に入り、整定シーク時間の残りの間そこに留まるために必要な平均時間。整定時間とは、中央基準レベル瞬時後、High 状態レベル周辺の許容誤差領域に信号が入ったまま留まるようになった時間です。このクロッシングを次の図に示します。

     整定時間のプロット

    整定シーク時間のパラメーターは、[設定] ペインで変更できます。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 settlingtime のリファレンスを参照してください。

  • – プレシュート — 各立ち下がり遷移の直前の領域にある平均最高逸脱。

  • – オーバーシュート — 各立ち下がり遷移の直後の領域にある平均最高逸脱。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 overshoot のリファレンスを参照してください。

  • – アンダーシュート — 各立ち下がり遷移の直後の領域にある平均最低逸脱。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 undershoot のリファレンスを参照してください。

  • - 整定時間 — 各立ち下がりエッジが Low 状態レベルの許容誤差内に入り、整定シーク時間の残りの間そこに留まるために必要な平均時間。整定時間とは、中央基準レベル瞬時後、Low 状態レベル周辺の許容誤差領域に信号が入ったまま留まるようになった時間です。整定シーク時間のパラメーターは、[設定] ペインで変更できます。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 settlingtime のリファレンスを参照してください。

[サイクル] ペインには、入力信号の表示部分内の反復またはトレンドを計算した測定値が表示されます。

  • [周期] — 入力信号の表示部分内の同じ極性の隣接するエッジ間の平均時間。[バイレベル測定] パネルは周期を次のように計算します。ここでは、各正極性パルスの初回遷移とその次の立ち上がり遷移のそれぞれの中央基準レベル瞬時における差を取得します。これらの中央基準レベル瞬時は赤い点で表示されます。

    この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 pulseperiod のリファレンスを参照してください。

  • [周波数] — 平均周期の逆数。周期は通常、秒の測定方式のいずれかまたはサイクルあたりの秒数で測定されるのに対し、周波数は一般に Hz または毎秒あたりのサイクルで測定されます。

  • [+ パルス] — カウントされた正極性パルス数。

  • [+ 幅] — 入力信号の表示部分内の各正極性パルスの立ち上がりエッジと立ち下がりエッジ間の平均時間。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 pulsewidth のリファレンスを参照してください。

  • [+ デューティ比] — 入力信号の表示部分内の各正極性パルスのパルス周期に対するパルス幅の平均比。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 dutycycle のリファレンスを参照してください。

  • [- パルス] — カウントされた負極性パルス数。

  • [- 幅] — 入力信号の表示部分内の各負極性パルスの立ち上がりエッジと立ち下がりエッジ間の平均時間。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 pulsewidth のリファレンスを参照してください。

  • [- デューティ比] — 入力信号の表示部分内の各負極性パルスのパルス周期に対するパルス幅の平均比。この計測で使用するアルゴリズムの詳細は、Signal Processing Toolbox 関数 dutycycle のリファレンスを参照してください。

ピークの検出パネル

[ピークの検出] パネルには最大値が表示され、その発生する x 軸上の値も示されます。ピークは、より低い値がピークの両側にある場合に、局所的最大値として定義されます。端点はピークとは見なされません。このパネルではピークしきい値、ピークの最大数、ピーク偏位の設定を変更できます。[ピークの検出] パネルは表示/非表示が選択できます。スコープ メニューから、[ツール][測定値][ピークの検出] を選択します。あるいは、スコープのツール バーで、[ピークの検出] ボタンをクリックします。

[ピークの検出] パネルは、2 つのペインに分割されており、それぞれ [設定] および [ピーク] というラベルが付けられています。各ペインを展開して使用できるオプションを確認できます。

[設定] パネルでは、入力信号の表示部分内のピーク値を計算するのに使用されるパラメーターを変更できます。このペインに使用されるアルゴリズムについての詳細は、『Signal Processing Toolbox findpeaks 関数リファレンス』を参照してください。

  • [ピークしきい値] — それを超えるとピークが検出されるレベル。この設定は、関数 findpeaks を実行するときに設定できる MINPEAKHEIGHT パラメーターと等価です。

  • [ピークの最大数] — 表示するピークの最大数。入力する値は 1 から 99 までのスカラー整数でなければなりません。この設定は、関数 findpeaks を実行するときに設定できる NPEAKS パラメーターと等価です。

  • [最小ピーク距離] — 隣接するピーク間のサンプルの最小数。この設定は、MINPEAKDISTANCE パラメーターと同じです。これは、関数 findpeaks を実行するときに設定できます。

  • [ピーク偏位] — ピークと隣接するサンプル間の高さの最小差。ピーク偏位の設定は、関数 findpeaks を実行する際に設定できるパラメーター THRESHOLD と等価です。

  • [ラベル形式] — プロット上の計算されたピーク値の隣に表示する座標。ピーク値を表示するには、[ピーク] ペインを展開し、対象のそれぞれのピークに対応するチェック ボックスを選択します。既定では、x 軸の値と y 軸の値の両方がプロット上に表示されます。表示領域上の各ピーク記号の隣に表示する軸の値を選択します。

    • [X+Y] — x 軸と y 軸の両方の値を表示します。

    • [X] — x 軸の値のみ表示します。

    • [Y] — y 軸の値のみ表示します。

[ピーク] ペインには計算された最大ピーク値のすべてが表示されます。[設定] ペインで定義したパラメーターを使用して、ピークが発生した座標も表示します。[ピークの最大数] パラメーターを設定し、一覧表示されるピークの数を指定します。

[値] 列に表示される数値は、関数 findpeaks の実行により返される出力引数 pks と等価です。第 2 列に表示される数値は、関数 findpeaks を実行すると返される出力引数 locs と同様です。

[ピークの検出] では、[ピーク] ペインにピーク値が表示されます。既定では、[ピークの検出] パネルでは、計算された最大ピーク値が [ピーク] ペインに、ピークの高い順に表示されます。[ピークの検出] でピーク値を表示するカテゴリと順序を並べ替えるには、降順に並べ替えるボタン () を使用します。このボタンを再度クリックすると、ピークが昇順で並べ替えられます。これを行うと矢印の向きが変わり、昇順に並べ替えるボタン () になります。並べ替えボタンが塗りつぶされている場合、ピーク値がボタン矢印の方向に現在並べ替えられていることを表します。並べ替えボタンが塗りつぶされていない場合 ()、ピーク値はボタン矢印と反対の方向に並べ替えられています。[ピークの最大数] パラメーターもまた一覧表示されるピークの数を制御しています。

チェック ボックスを使用して、表示領域に表示するピーク値を制御します。既定ではすべてのチェック ボックスがオフになっており、[ピークの検出] パネルではすべてのピーク値が非表示となります。表示領域にすべてのピーク値を表示するには、[ピーク] ペインの左上隅にあるチェック ボックスをオンにします。表示領域ですべてのピーク値を非表示にするには、このチェック ボックスをオフにします。個々のピークを表示するには、そのピークの [値] リストの左にあるチェック ボックスをオンにします。個々のピークを非表示にするには、そのピークの [値] リストの左にあるチェック ボックスをオフにします。

ピークは入力信号のどの単位についても有効です。各測定の対応値の後に続く文字は、mmilli を表すなど、SI (国際単位系) の適切な接頭辞の省略形を表します。たとえば、入力信号がボルトで測定される場合、測定値の横の m は、この値がミリボルト単位であることを表します。

ビジュアル — 時間領域オプション

[ビジュアル — 時間領域プロパティ] ダイアログ ボックスでは、信号ブラウザー表示領域の外観を設定します。このダイアログ ボックスを開くには、メニューから [表示][コンフィギュレーション プロパティ] を選択します。

[メイン] ペイン

[ビジュアル — 時間領域プロパティ] ダイアログ ボックスの [メイン] ペインは、次のように表示されます。

時間単位

time 軸の表記で使用する単位を指定します。既定の設定は、[基準] です。以下のオプションのいずれかを選択します。

  • [基準] — このモードでは、信号ブラウザーにより time 軸上の時間がミリ秒、マイクロ秒、日などの計量単位に変換されます。信号ブラウザーは、ウィンドウの最小 time 軸範囲と最大 time 軸範囲に基づいて適切な計量単位を選択します。

  • [秒] — このモードでは、信号ブラウザーは time 軸上の単位を常に秒で表示します。

  • [なし] — このモードでは、信号ブラウザーは time 軸上には単位を表示しません。time 軸には、Time という単語のみが表示されます。

時間軸ラベル

time 軸の表記に使用する時間単位の表示方法を指定します。既定の設定は、[すべて] です。以下のオプションのいずれかを選択します。

  • [すべて] — このモードでは、time 軸ラベルはすべての表示領域で表示されます。

  • [なし] — このモードでは、time 軸ラベルは表示領域に表示されません。

  • [下部表示のみ] — このモードでは、time 軸のラベルは表示の一番下の行にのみ示されます。

時間軸ラベルの表示

選択すると、time 軸ラベル表示がオンになります。

座標軸の最大化

信号ブラウザーを軸の最大化モードで表示するかどうかを指定します。このモードでは、それぞれの座標軸は表示領域全体に合わせて拡張されます。各表示領域にはラベルを表示するスペースはありません。プロットされたデータの上に目盛りの値が表示されます。既定の設定は、[自動] です。以下のオプションのいずれかを選択します。

  • [自動] — このモードでは、各表示領域に対して [タイトル] および [Y 軸ラベル] パラメーターが空の場合に限り、軸は表示領域全体に広がるように最大化されます。いずれかの表示領域でこれらのパラメーターのどちらかに値を入力すると、軸は最大化されません。

  • [オン] — このモードでは、すべての表示で座標軸が最大化されます。[タイトル] および [Y 軸ラベル] パラメーターに入力された値は表示されません。

  • [オフ] — このモードでは、いずれの軸も最大化されません。

表示ペイン

[ビジュアル — 時間領域プロパティ] ダイアログ ボックスの [表示] ペインは、次のように表示されます。

アクティブな表示

整数でアクティブ表示を指定し、関連するプロパティを取得または設定します。表示領域の番号は、その列方向の配置インデックスに対応します。このプロパティで、どの表示領域の座標軸の色、ラインのプロパティ、マーカーのプロパティ、表示/非表示を変更するかを制御します。

[レイアウト] オプションを使用してウィンドウを複数の表示領域に分けて並べて表示する場合、青で強調表示された表示領域は "アクティブな表示領域" と呼ばれます。既定の設定は 1 です。

タイトル

アクティブな表示領域のタイトルをテキストとして指定します。既定では、アクティブな表示領域にはタイトルがありません。

凡例の表示

表示領域に凡例を表示する場合は、このチェック ボックスをオンにします。チャネルの凡例には、各入力信号の各チャネルの名前が表示されます。凡例が表示されたら、スコープ ウィンドウ内の任意の場所に配置できます。凡例を非表示にするには、[凡例の表示] チェック ボックスをオフにします。

凡例内の任意のチャネルの名前を編集するには、現在の名前をダブルクリックし、新しいチャネル名を入力します。既定では、信号に複数のチャネルがある場合、スコープはインデックス番号を使用して信号の各チャネルを識別します。スコープ ウィンドウで入力信号のチャネルの外観を変更するには、メニューから [表示][スタイル] を選択します。凡例を使用して、どの信号を表示するかを変更できます。信号を 1 つだけ表示する場合は、信号名をクリックします。信号のオン/オフを切り替えるには、信号名を右クリックします。

グリッド表示

このチェック ボックスをオンにすると、スコープの図の表示領域にグリッドが表示されます。グリッドを非表示にするには、このチェック ボックスをオフにします。

信号を振幅および位相としてプロット

このチェック ボックスをオンにすると、スコープは表示領域を振幅プロットと位相プロットに分割します。既定の設定では、このチェック ボックスはオフです。入力信号が複素数の値をもつ場合、スコープは実数部と虚数部を同一軸上にプロットします。次の図に示すように、これらの実数部と虚数部は同一軸上に異なる色の線で表示されます。

このチェック ボックスをオンにし、[適用] または [OK] ボタンをクリックすると、表示領域が変化します。入力信号の振幅は、上の座標軸に表示され、その位相は、下の座標軸に度単位で表示されます。下の図を参照してください。

この機能は、複素数値の入力信号の場合に役に立ちます。入力が実数値の信号である場合、このチェック ボックスをオンにすると、振幅について信号の絶対値が返されます。位相は、非負の入力の場合には 0°、負の入力の場合には 180°になります。

Y 軸範囲 (最小)

y 軸の最小値を指定します。

[信号を振幅および位相としてプロット] チェック ボックスをオンにすると、このプロパティの値が上の座標軸のゲイン プロットに常に適用されます。下の座標軸における位相プロットは、最小値の -180 度に常に制限されます。

Y 軸範囲 (最大)

y 軸の最大値を指定します。

[信号を振幅および位相としてプロット] チェック ボックスをオンにすると、このプロパティの値が上の座標軸のゲイン プロットに常に適用されます。下の座標軸の位相プロットは、最大値の 180 度に常に制限されます。

Y ラベル

y 軸の左に表示するスコープの文字を指定します。

このプロパティは、[信号を振幅および位相としてプロット] チェック ボックスをオンにすると非表示になります。このプロパティを有効にすると、y 軸のラベルは常に、上の座標軸では Magnitude として表示され、下の座標軸では Phase として表示されます。

スタイル ダイアログ ボックス

[スタイル] ダイアログ ボックスでは、表示領域のスタイルをカスタマイズできます。表示領域を含む Figure の色、表示軸の背景や前景の色、表示領域内のラインのプロパティを変更できます。信号ブラウザーのメニューから、[表示][スタイル] を選択してこのダイアログ ボックスを開きます。

プロパティ

[スタイル] ダイアログ ボックスでは、信号ブラウザーの次のプロパティを変更できます。

Figure の色

信号ブラウザーの背景に適用する色を指定します。既定では、Figure の色は灰色です。

プロット タイプ

使用するプロットのタイプを指定します。既定の設定は [ライン] です。[プロット タイプ] の有効な値は次のとおりです。

  • [ライン] — サンプリングされた値のそれぞれを結ぶラインとして入力信号を表示します。この方法は、MATLAB 関数の line または plot の機能に似ています。

  • [階段状プロット] — 入力信号を "階段状" のグラフとして表示します。階段状グラフは、水平線と垂直線でのみ構成されています。各水平線は、離散サンプル期間の信号値を表し、2 本の垂直線に接続されます。各垂直線は、サンプルに発生している値の変化を表します。この方法は、MATLAB の関数 stairs と同等です。階段状プロットは、デジタル的にサンプリングされたデータの時間履歴のグラフを描画する際に有効です。

表示の選択

アクティブにする表示を番号で指定します。表示番号は入力信号のインデックスに対応します。表示領域の番号は、その列方向の配置インデックスに対応します。既定の設定は 1 です。このパラメーターはどの Axes の色、ラインのプロパティ、マーカーのプロパティおよび表示/非表示を変更するかを制御するために設定します。

Axes の色

アクティブな表示領域の座標軸の背景に適用する色を指定します。

クリップボードへのコピーで色を保持

スコープのコピー時に表示されている色をそのまま使用するかどうかを指定します。

[ファイル][クリップボードにコピー] を選択すると、ソフトウェアによってスコープの色がプリンター用 (背景色が白、ラインを表示) に変更されます。表示された色のままスコープをコピーして貼り付けるには、このチェック ボックスをオンにします。

既定の設定: オフ

ラインのプロパティ

可視性、ラインのプロパティおよびマーカーのプロパティを変更する信号を指定します。

表示

アクティブな表示領域上で選択された信号を表示するかどうかを指定します。このチェック ボックスをオフすると、ラインが非表示になります。

ライン

アクティブな表示領域における選択された信号の、ラインのスタイル、幅および色を指定します。

マーカー

アクティブな表示領域上で選択された信号のマークをデータ点で表示するように指定します。このパラメーターは、MATLAB Handle Graphics® プロット オブジェクトの Marker プロパティに似ています。次の表のマーカー記号が選択できます。

指定子マーカー タイプ
なしマーカーなし (既定の設定)
正方形
十字
プラス記号
アスタリスク
菱形
下向き三角形
上向き三角形
左向き三角形
右向き三角形
星形五角形
星形六角形

フィルター デザイナー アプリ

フィルター デザイナーアプリによって、FIR および IIR フィルターを設計および編集できます。アプリを起動するには、SPTool の [フィルター] リスト ボックスで [新規作成] ボタンまたは [編集] ボタンをクリックします。

フィルター デザイナー アプリには極-零点エディターが装備されており、左列にある アイコンを選択してアクセスすることができます。

フィルターの可視化ツール

フィルターの可視化ツール (fvtool) では、振幅応答、位相応答、群遅延、位相遅延、極-零点プロット、インパルス応答、ステップ応答などの、設計されたフィルターまたはインポートされたフィルターの特性を表示できます。FVTool をアクティブにするには、SPTool の [フィルター] リスト ボックスで [表示] ボタンをクリックします。

スペクトル ビューアー

スペクトル ビューアーでは、バーグ法、FFT 法、マルチテーパー法、MUSIC 固有ベクトル法、ウェルチ法、ユール・ウォーカー自己回帰法など、さまざまなスペクトル密度推定法を使用して、周波数領域データのグラフィカルな解析を実行できます。スペクトル ビューアーを起動するには、次の手順にしたがいます。

  • [スペクトル] リスト ボックスの下にある [作成] ボタンをクリックして、SPTool の [信号] リスト ボックスで選択した信号に対するパワー スペクトル密度を計算します。スペクトルを表示するには、[適用] をクリックしなければならない場合があります。

  • [表示] ボタンをクリックして、SPTool の [スペクトル] リスト ボックスで選択したスペクトルを解析します。

  • SPTool の [スペクトル] リスト ボックスの下にある [更新] ボタンをクリックして、選択したパワー スペクトル密度信号を編集します。

また、プロット表示領域の任意の場所を右クリックして、信号プロパティを編集することができます。

MATLAB コマンド ラインからの SPTool の制御

コマンド ラインを使用して、SPTool からデータをインポートまたはエクスポートすることができます。

SPTool からのコンポーネント構造のエクスポート

次のコマンドは、現在開いている SPTool からコンポーネント構造をエクスポートします。

  • s = sptool('Signals') はすべての信号の構造体配列を返します。

  • f = sptool('Filters') はすべてのフィルターの構造体配列を返します。

  • s = sptool('Spectra') はすべてのスペクトルの構造体配列を返します。

  • [s,ind] = sptool(___) は、SPTool で s の要素のどれが現在選択されているかを示す指標ベクトルを返します。

  • s = sptool(___,0) は、現在選択されているオブジェクトのみを返します。

コンポーネント構造体の作成と読み込み

以下のコマンドは、コンポーネント構造体を作成し、それらを SPTool、必要に応じて開いている SPTool、に読み込みます。

  • struc = sptool('create',paramlist) は、ワークスペース内に paramlist によって定義される、コンポーネント構造体 struc を作成します。

    sptool('load',struc)struc を SPTool に読み込みます。

  • struc = sptool('load',paramlist) は、paramlist によって定義されるコンポーネント構造体を SPTool に読み込みます。出力引数を指定した場合、コマンドはワークスペース内にコンポーネント構造体の作成も行います。

例: カットオフ周波数 0.5π ラジアン/サンプルをもつ 5 次のバタワース フィルターを作成して読み込みます。状態空間表現でフィルターを指定し、SPTool 内でそれを Butterworth でラベル付けし、1 kHz でサンプリングされたデジタル信号をフィルター処理するように設定します。

[z,p,k] = butter(5,0.5);
struc = sptool('create','Filter','zpk',z,p,k,1e3,'Butterworth');
sptool('load',struc)

例: ホワイト ノイズに組み込まれた 512 サンプルの正弦波信号のピリオドグラム PSD 推定を SPTool に読み込みます。正規化された単位で作業を行い、π/4 ラジアン/サンプルの正弦波周波数を指定します。SPTool 内のスペクトル PSD をラベル付けします。

n = 0:511;
x = sin(pi/4*n)+randn(size(n))/10;
[pxx,w] = periodogram(x);
sptool('load','Spectrum',pxx,w,'PSD')

例: ガウス変調された 2 次チャープを作成して読み込みます。2 kHz のサンプルレートと 2 秒の信号持続時間を指定します。ワークスペースに構造体のコピーを生成します。

t = 0:1/2000:2-1/2000;
q = chirp(t-2,4,1/2,6,'quadratic',100,'convex').*exp(-4*(t-1).^2);
Chirp = sptool('load',q,2000)
Chirp = 

  struct with fields:

             data: [4000×1 double]
               Fs: 2000
             type: 'vector'
         lineinfo: []
    SPTIdentifier: [1×1 struct]
            label: 'sig'

paramlist のパラメーターは次の順序で入力しなければなりません。

コンポーネントparamlist パラメーター
信号component_namedatafslabel
フィルターcomponent_nameformfilter_paramsfslabel
スペクトルcomponent_namedataflabel

パラメーターの定義は以下のとおりです。

パラメーター定義
component_name

'Signal''Filter'、または 'Spectrum' のいずれかとして指定します。指定しなかった場合、component_name には既定値の 'Signal' が設定されます。

form

フィルターの形式または構造体。'tf''ss''sos'、または 'zpk' のいずれかとして指定します。

data信号またはスペクトルを表す doubles 型のベクトル。
filter_params

フィルターの表現。

  • form'tf' の場合 numden を指定。

  • form'sos' の場合 SOS 行列を指定。

  • form'zpk' の場合 zp および k を指定。

  • form'ss' の場合、ABC および D を指定。

fs

サンプルレートを指定するオプションのパラメーター。指定しなかった場合、fs には既定値の 1 が設定されます。

f

周波数ベクトル。このパラメーターは component_name'Spectrum' である場合にのみ適用されます。

label

SPTool 内のコンポーネントの変数名を指定するオプションのパラメーター。指定しなかった場合の label の既定値は以下です。

  • component_name'Signal' の場合 'sig'

  • component_name'Filter' の場合 'filt'

  • component_name'Spectrum' の場合 'spec'

R2006a より前に導入