Main Content

Window Layouts

The RoadRunner UI is organized into panels. You can customize the layout of the panels to meet your preferences by resizing the panels and moving them into different configurations. RoadRunner preserves the window layout from session to session.

You can save and name up to five different layouts. You can restore saved layouts by using the layout controls at the bottom of the window menu.

Switch Between Tabbed Panels

Panels can be stacked on top of each other. By default, the Output Panel and Library Browser panel are tabbed.

To switch between tabbed panels, click the applicable tab at the bottom of the panel.

Undock a Panel

You can move a panel to a separate window (for example, to move it to a different monitor) by clicking and dragging the top of the panel. After moving a panel to a new window, you can move and resize this panel independently from the main application.

Dock a Panel

You can change where panels are docked in the application. This option can be useful for making better use of screen real estate on wide monitors.

  1. Click and drag the top of the panel (this action works for docked and undocked panels).

  2. Hover over the edge of the application where you would like to dock the panel.

    • If you hover over the edge of the application without an existing panel, the panel will be docked to that edge.

    • If you hover over the middle of another panel, the panel will be docked on top of that panel (that is, the panels will be tabbed).

    • If you hover over the left or right side of a bottom panel (or the top or bottom of a side panel), then both panels will be displayed next to each other.

Save the Current Window Layout

  1. Select the Window > Save Layout menu option. A dialog box prompts you to name the layout. If you already have five layouts saved, saving another layout will replace the oldest saved layout.

  2. Type in the desired name of the layout. If you type in the name of an existing layout, the new layout will replace that existing layout.

Restore a Saved Window Layout

Select the Window > Apply Layout > (layout) menu option, where (layout) is the name of the layout you want to restore.

Delete a Saved Window Layout

Select the Window > Delete Layout > (layout) menu option, where (layout) is the name of the layout you want to delete.

Reset the Window Layout to the Default Layout

Select the Window > Reset Layout menu option.