ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

デスクトップのレイアウトの最適化

デスクトップのレイアウト

デスクトップ ツールを閉じる、最小化、アンドックを行って、デスクトップのレイアウトを最適化できます。気に入ったレイアウトができたら、保存して再利用できます。

次の表は、画面上で MATLAB® デスクトップのレイアウトを最適化する方法を示しています。MATLAB Online™ デスクトップを最適化するには、MATLAB Online のデスクトップのレイアウトを参照してください。

アクション手順

MATLAB ツールストリップを最小化または復元する

最小化するには、ツールストリップの右下隅で をクリックします。

復元するには、タブ ラベルのいずれかを選択し、ツールストリップの右下隅で をクリックします。

ツールを開くまたは非表示にする

[ホーム] タブの [環境] セクションで、[レイアウト] をクリックします。次に、[表示] の下で、表示または非表示にするデスクトップ ツールを選択またはクリアします。

関数を使ってデスクトップ ツールを開くこともできます。たとえば、エディターを開くには、edit を使用します。プロファイラーを開くには、viewer オプションを指定して profile を使用します。

ツールを最大化する

以下のいずれかを行います。

  • ツールのタイトル バーをダブルクリックする

  • ドッキングされたツールのタイトル バー上で をクリックし、[最大化] を選択する

ツールを最小化する

ドッキングされたツールのタイトル バー上で をクリックし、[最小化] を選択します。

ツールのボタンは、[最小化] アイコンの矢印で示される MATLAB デスクトップの端に沿って表示されます。デスクトップの別の端に移動させるには、ボタンをドラッグします。

最小化されたツールを使用するには、ツールのボタンをクリックして、ツールをデスクトップに一時的に開きます。ツールの使用が終了したら、別のツールをクリックします。

ツールを最大化または最小化する前の状態に復元する

以下のいずれかを行います。

  • 最大化されたツールのタイトル バーまたは最小化されたツールのボタンをダブルクリックする。

  • ツールのタイトル バーで をクリックし、[元に戻す] を選択する。

  • ツールのタイトル バーの [元に戻す] ボタン をクリックする。

ツールを移動する

ツールのタイトル バーをドラッグして、新しい位置まで移動します。ステータス バーは、マウスを離すと移動される位置を示します。

ツールを閉じる

ドッキングされたツールのタイトル バー上で をクリックし、[閉じる] を選択します。

タイトル バーを表示または非表示にする

[ホーム] タブの [環境] セクションで、[レイアウト] をクリックします。次に、[表示] の下で [パネル タイトル] を選択またはクリアします。

ツール バーを Figure ウィンドウで表示または非表示にする

[表示] メニューから該当するツール バーを選択します。

ツールをアンドックしてデスクトップ外に移動する

以下のいずれかを行います。

  • ツールのタイトル バーをドラッグして、MATLAB デスクトップ外の別の位置まで移動する。

  • ツールのタイトル バー上で をクリックし、[ドックから出す] を選択する。

アンドックされたツールをデスクトップへ戻す

ツール パネルの右上で をクリックし、[ドックに入れる] を選択します。

デスクトップの配置を管理する

  • 配置を保存する

  • 配置を使用する

  • 保存された配置を名前変更または削除する

[ホーム] タブの [環境] セクションで [レイアウト] をクリックし、オプションを選択します。

MATLAB はユーザーが保存した配置を MATLAB の設定フォルダーに XML ファイルとして保存します。セッションの最新のレイアウトは MATLABDesktop.xml に保存されています。MATLABDesktop.xml ファイルは、MATLAB の起動時に読み込まれ、MATLAB の終了時に上書きされます。

セッションを終了すると、MATLAB は現在のデスクトップの配置を保存します。次回 MATLAB を起動すると、デスクトップは前回終了したときと同じ外観になります。なお、ヘルプ ブラウザー、Web ブラウザー、変数エディターなどのツールは、前回のセッションの終了時に開いていても起動時に自動的には開きませんが、起動オプションを使うと、起動時に開くツールを指定できます。詳細は、起動オプションの指定を参照してください。起動オプションは、MATLAB Online では利用できません。

MATLAB Online のデスクトップのレイアウト

MATLAB Online では、標準の Web ブラウザーから MATLAB にアクセスできます。MATLAB Online でデスクトップのレイアウトを変更するには、[ホーム] タブで [レイアウト] をクリックし、オプションを選択します。個々のツールを移動するには、ツールのタイトル バーをドラッグして、新しい場所に移動します。MATLAB Online では、ツールをアンドックすることはできません。

ツールを最小化するには、ツールが存在しているパネルを折りたたみます。たとえば、MATLAB Online のデスクトップが既定のレイアウトになっていて、現在のフォルダー ブラウザーが左側のパネルに配置されている場合、パネルの左下隅にある ボタンをクリックしてパネルを折りたたみます。パネルを元に戻すには、 ボタンをクリックします。

左側のパネル、または右側のパネルに複数のツールが含まれている場合は、ツールのタイトル バーの左側にある ボタンをクリックすると、個々のツールを最小化できます。下部パネル内の複数のツールはタブとして表示され、最小化することはできません。

ドキュメントのレイアウト

MATLAB ドキュメントを開くと、ドキュメントはエディターや変数エディターなど、関連付けられたツールで開かれます。エディターと変数エディターは、前回使用したときの位置に表示されます。アンドックされたドキュメントの項目は、Windows® のタスク バー、またはプラットフォームでそれに対応するものに表示されます。タスク バーにあるドキュメントの項目をクリックすると、そのドキュメントがアクティブになります。

次の表に、ツール内でドキュメントのレイアウトを最適化する方法を示します。

アクション手順

タブ位置を変更する

[表示] タブの [ドキュメント タブ] セクションで [タブ位置] をクリックし、オプションを選択します。

MATLAB Online では、ツールのタイトル バーで をクリックし、[タブの位置] を選択し、オプションを選択します。

ドキュメントを並べ替える

ドキュメント タブを別の位置にドラッグします。

ドキュメント名をアルファベット順に並べるには、[表示] タブの [ドキュメント タブ] セクションで [アルファベット順] を選択します。

ドキュメントを整列または並べて表示する

エディターと変数エディターで [表示] タブを選択します。[並べて表示] セクションで整列オプションを選択します。

Figure パネル、ヘルプ ブラウザーまたは Web ブラウザーで、ツール バーの右側にある整列オプション または を選択します。

MATLAB Online では、ツールのタイトル バーで をクリックし、[すべて並べて表示] を選択し、タイル オプションを選択します。

整列されたドキュメントを移動する

ドキュメント タブを別のタイルにドラッグします。既にドキュメントを含んでいるタイルにドラッグした場合、2 つのドキュメントは重なり、ドラッグしたドキュメントが上に表示されます。

ドキュメントのアンドック

ドキュメント タブを右クリックし、[ドックから出す] を選択します。

現在表示中のドキュメントを閉じて保存

をクリックします。

エディターのドキュメントを保存せずに閉じる

Ctrl + をクリックします。