ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

イメージ ビューアー アプリを使用したイメージの調査

概要ツールを使用したイメージの調査

イメージが大きい場合や大きい倍率で表示する場合、イメージ ビューアーではイメージの一部のみが表示され、イメージのナビゲートに使用するスクロール バーが自動的に表示されます。イメージ ビューアーで現在表示されているイメージの部分を特定するには、概要ツールを使用します。概要ツールでは、イメージ全体が画面に収まるようにスケールされて表示されます。イメージのこのビューの上には、"詳細四角形" と呼ばれる四角形が重ねて表示されます。詳細四角形は、現在イメージ ビューアーに表示されているイメージの部分を示します。概要ツールで詳細四角形を移動すると、イメージ ビューアーに表示されるイメージの部分を変更できます。

以下の節では、概要ツールの使用に関する詳細を説明します。

概要ツールの起動

概要ツールは、イメージ ビューアーのツール バーで [概要] ボタン をクリックするか、イメージ ビューアーの [ツール] メニューから [概要] オプションを選択して起動できます。また、イメージ ビューアーを開く際に概要ツールが自動的に開くように設定を変更することもできます。設定方法の詳細は、iptprefs を参照してください。

詳細四角形の移動によるイメージ表示の変更

  1. イメージ ビューアーのツール バーの [概要] ボタン をクリックするか、[ツール] メニューから [概要] を選択して概要ツールを起動します。別のウィンドウに概要ツールが開き、画面に合わせてスケールされたイメージ全体が表示されます。

    概要ツールが既にアクティブであれば、[概要] ボタンをクリックすると、画面に開いているウィンドウの一番手前にツールが表示されます。

  2. マウスを使用して、ポインターを詳細四角形内に移動します。ポインターが花形 に変わります。

  3. マウス ボタンを押したままイメージの任意の場所に詳細四角形をドラッグします。イメージ ビューアーによってイメージの表示が更新され、指定した領域が表示されます。

詳細四角形の色の指定

既定の設定では、概要ツールの詳細四角形の色は青です。四角形の色は、その下にあるイメージの主要な色とのコントラストを向上させるために変更できます。そのためには、詳細四角形の境界内の任意の場所を右クリックして、コンテキスト メニューから [色の設定] を選択します。

詳細四角形のサイズと位置の取得

詳細四角形の現在位置とサイズを取得するには、四角形内の任意の場所を右クリックして表示されたコンテキスト メニューから [位置のコピー] を選択します。このオプションには、オーバービュー ツールの [編集] メニューからもアクセスできます。

このオプションは、位置情報をクリップボードにコピーします。位置情報は、[xmin ymin width height] の形式のベクトルです。この位置ベクトルは MATLAB® ワークスペースまたは別のアプリケーションに貼り付けることができます。

概要ツールでのイメージ表示の印刷

概要ツールに表示されたイメージを印刷できます。概要ツールの [ファイル] メニューから [Figure に出力] オプションを選択します。詳細は、イメージの印刷 を参照してください。

イメージ ビューアー アプリに表示されたイメージの移動

イメージ ビューアーで表示されるイメージの部分を変更するには、移動ツールを使用してウィンドウに表示されるイメージを移動します。これをイメージの "移動" と呼びます。

  1. ツール バーの [移動] ツール ボタン をクリックするか、[ツール] メニューから [移動] を選択します。移動ツールがアクティブな場合、メニューの移動選択肢の横にチェック マークが表示されます。

  2. マウスを使用してイメージ ビューアーのイメージの上にポインターを移動します。ポインターが開いた手の形状 に変わります。

  3. マウス ボタンを押したままイメージ ビューアー内でイメージをドラッグします。イメージをドラッグするときは、ポインターは閉じた手の形状 に変わります。

  4. 移動をオフにするには、移動ツールのボタンを再度クリックするか、[ツール] メニューの [移動] オプションをクリックします。

メモ:

イメージ ビューアーでイメージを移動すると、概要ツールによって詳細四角形の位置が更新されます (概要ツールを使用したイメージの調査を参照)。

イメージ ビューアー アプリでのイメージのズーム

クローズアップで見るためにイメージを拡大するか、より多くのコンテキストを見るためにイメージを縮小するには、ツール バー上のズーム ボタンを使用します。倍率を変更するか (イメージ ビューアーでのイメージの倍率指定を参照)、Ctrl+Plus キーまたは Ctrl+Minus キーを使用してイメージを拡大または縮小することもできます。これらは、キーボードの数値キーパッドの Plus(+) キーと Minus(-) キーです。

  1. イメージ ビューアーのツール バーで適切な虫眼鏡ボタンをクリックするか、[ツール] メニューで [ズーム イン] オプションまたは [ズーム アウト] オプションを選択します。ズーム ツールがアクティブな場合、メニューの適切なズーム選択肢の横にチェック マークが表示されます。

  2. マウスを使用して、ズームインまたはズーム アウトするイメージの上にポインターを移動します。ポインターは適切な虫眼鏡アイコンに変わります。クリックするたびにイメージの倍率が変わり、クリックした場所を中心にイメージが新しく表示されます。

    イメージをズームインまたはズーム アウトすると、イメージ ビューアーによって倍率エディット ボックスに表示された倍率値が変更されます。さらに、概要ウィンドウで詳細四角形の位置が更新されます。

  3. ズーム モードを終了するには、アクティブなズーム ボタンを再びクリックして選択を解除するか、[ツール] メニューで [ズーム] オプションをクリックします。

イメージ ビューアーでのイメージの倍率指定

イメージを拡大または縮小するには、次の図に示すように、倍率エディット ボックスを使用します。(ズーム ボタンを使用してイメージを拡大または縮小することもできます。詳細は、イメージ ビューアー アプリでのイメージのズームを参照してください)。

イメージの倍率を変更するには、以下の手順に従います。

  1. ポインターを倍率エディット ボックスの中に移動します。ポインターは、テキスト エントリ カーソルに変化します。

  2. 倍率エディット ボックスに新しい値を入力し、Enter キーを押します。イメージ ビューアーによってイメージの倍率が変更され、ウィンドウに新しいビューが表示されます。

倍率エディット ボックスに関連したメニューをクリックし、前もって設定されている大きさのリストから選択することで、倍率を指定することもできます。[ウィンドウに合わせる] オプションを選択すると、イメージ ビューアーはイメージ全体が表示されるようにイメージをスケールします。