ドキュメンテーション

このページは前リリースの情報です。該当の英語のページはこのリリースで変更されています。最新情報を確認するには、ページ左下にある国リストで [United States] を選択し、英語ドキュメンテーションに切り替えてください。

wintool

ウィンドウの設計と解析ツールを起動

構文

wintool

説明

wintool は、ウィンドウの設計と解析ツール (WinTool)、スペクトル ウィンドウの設計および解析用ツールのグラフィカル ユーザー インターフェイス (GUI) を開きます。Wintool には、既定で 64 点ハミング ウィンドウが表示されます。

    メモ:   ウィンドウの表示、注釈付け、印刷用に、関連するツール wvtool が用意されています。

wintool には、以下の 3 つのパネルがあります。

  • ウィンドウ ビューアーには、選択したウィンドウを時間領域と周波数領域で表現したものが表示されます。現在のアクティブなウィンドウは、太字で表示されます。プロットの下には、次の 3 つのウィンドウ測定値が表示されます。

    • リーケージ ファクター — ウィンドウ全体のパワーに対するサイドローブ内のパワーの比

    • 相対的サイドローブ減衰比 — メインローブのピークと、最も高いサイドローブのピークの高さの差

    • メインローブ幅 (–3 dB) — メインローブのピークより 3 dB 低い位置でのメインローブの幅

  • [ウィンドウ リスト] には、ウィンドウ ビューアーに表示可能なウィンドウがリストされます。1 つ以上のウィンドウを強調表示すると、これらのウィンドウが表示されます。[ウィンドウ リスト] には、次のボタンがあります。

    • 新規ウィンドウの追加 — 長さが 64 で、対称サンプリングが行われる既定のハミング ウィンドウを追加します。[現在のウィンドウ情報] パネルで行った変更内容を適用して、このウィンドウの情報を変更できます。

    • ウィンドウのコピー — 選択しているウィンドウをコピーします。

    • ワークスペースへ保存 — 選択しているウィンドウをベクトルとして、MATLAB® のワークスペースに保存します。ベクトル名には、wintool でのウィンドウ名が使用されます。

    • 削除 — 選択しているウィンドウを [ウィンドウ リスト] から削除します。

  • [現在のウィンドウ情報] には、現在アクティブなウィンドウに関する情報が表示されます。アクティブなウィンドウ名は、Name フィールドに表示されます。別のウィンドウをアクティブにするには、[名前] メニューからウィンドウ名を選択します。

ウィンドウ パラメーター

各ウィンドウは、[現在のウィンドウ情報] パネルのパラメーターにより定義されます。現在のウィンドウの特性を変更するには、対応するパラメーターを変更して [適用] をクリックします。現在のウィンドウのパラメーターとしては、以下のものがあります。

  • 名前 — ウィンドウ名。この名前は、ウィンドウ ビューアーやウィンドウ リストでの凡例や、ワークスペースへ保存するベクトルに使用されます。メニューから名前を選択することや、希望する名前をエディット ボックスに入力することができます。

  • タイプ — ウィンドウのアルゴリズム。メニューからタイプを選択します。Signal Processing Toolbox™ のすべてのウィンドウを使用できます。

  • MATLAB コードType = User Defined の場合、ウィンドウを定義するベクトルを返す任意の有効な MATLAB ステートメント。

  • 長さ — サンプルの数。

  • パラメーター — ウィンドウで必要なその他のパラメーター。たとえばチェビシェフの場合は、サイドローブの減衰量を指定する必要があります。[パラメーター] というタイトルが、対応するパラメーター名に変わります。

  • サンプリング ― 一般化されたコサイン ウィンドウ (ハミング、ハン、ブラックマン) で使用するサンプリングのタイプ ― Periodic または Symmetric です。Periodic では、n+1 の長さのウィンドウが計算され、最初の n 点が返されます。Symmetric では、Length 内で指定された n 点が返されます。

WinTool メニュー

wintool には、通常のメニュー項目のほかに、wintool 固有の以下のメニュー コマンドが含まれています。

[ファイル] メニュー:

  • エクスポートウィンドウ係数ベクトルを MATLAB ワークスペース、テキスト ファイルまたは MAT ファイルにエクスポートします。

    WinTool の [ウィンドウ リスト] でエクスポートするウィンドウを強調表示し、[ファイル][エクスポート] を選択します。ワークスペースまたは MAT ファイルにエクスポートする場合は、ウィンドウ係数の各セットに変数名を指定します。ワークスペースの変数を上書きするには、[変数を上書きする] チェック ボックスを選択します。

  • フル ビュー解析 — 2 つのプロットに表示されているウィンドウを別の wvtool の Figure ウィンドウにコピーします。印刷や注釈付けを行う場合に、この機能が役立ちます。ツール バーの [フル ビュー解析] ボタンから、このオプションを使用することもできます。

[表示] メニュー:

  • 時間領域 — [ウィンドウ ビューアー] パネルに、時間領域のプロットを表示する場合に選択します。

  • 周波数領域 — [ウィンドウ ビューアー] パネルに、周波数領域のプロットを表示する場合に選択します。

  • 凡例 — ウィンドウ名の凡例の表示/非表示を切り替えます。ツール バーの [凡例] ボタンから、このオプションを使用することもできます。

  • 解析パラメーター — データ数、範囲、x 軸と y 軸の単位、サンプリング周波数など、応答プロットのパラメーターをコントロールします。

    また、ウィンドウの表示パネルにプロットされている x 軸ラベルを右クリックして、解析パラメーターにアクセスすることもできます。時間領域にプロットされている x 軸の単位は、選択されている Sampling Frequency の単位によって決まります。

    周波数領域

    時間領域

    Hz

    s

    kHz

    ms

    MHz

    µs

    GHz

    ns

[ツール] メニュー:

  • ズームインx 軸および y 軸をともに拡大します。

  • X 軸ズームx 軸のみを拡大します。x 方向にマウスをドラッグして、拡大領域を選択します。

  • Y 軸ズーム — y 軸のみを拡大します。y 方向にマウスをドラッグして、拡大領域を選択します。

  • フル ビュー — 全体表示に戻ります。

すべて折りたたむ

WinTool を使用して長さ 128 のボーマン ウィンドウを指定し、ワークスペースにエクスポートします。

  1. ボーマン ウィンドウを作成します。

    • [タイプ] リストから [ボーマン] を選択します。

    • [長さ] に「128」と入力します。

    • [名前] に「bohwin」と入力します。

  2. [適用] をクリックします。[ウィンドウ ビューアー] ボックスの時間および周波数領域にウィンドウが表示されます。

  3. [ワークスペースに保存] をクリックします。コマンド ラインで次のメッセージが確認できます。

    bohwin has been exported to the workspace.

  4. ワークスペースに新しいウィンドウがあることを確認します。

    whos bohwin
      Name          Size            Bytes  Class     Attributes
    
      bohwin      128x1              1024  double

WinTool を使用し、カイザー ウィンドウの動作がウィンドウ長と形状パラメーター β にどのように依存しているかを確認します。

  1. カイザー ウィンドウを作成します。

    • [タイプ] リストから [カイザー] を選択します。

    • [長さ] に「20」と入力します。

    • [ベータ] に「0」と入力します。

    • [名前] に「kaiser0」と入力します。

  2. [適用] をクリックします。[ウィンドウ ビューアー] ボックスの時間および周波数領域にウィンドウが表示されます。

  3. [新規ウィンドウの追加] をクリックします。長さ 20 で、ベータ3 のカイザー ウィンドウを作成します。ウィンドウの名前を kaiser3 として [適用] をクリックします。

  4. [ウィンドウのコピー] をクリックし、[ベータ]6 にして 3 番目のカイザー ウィンドウ kaiser6 を作成します。[適用] をクリックします。

  5. [ウィンドウ リスト] で 3 つのウィンドウを選択します。

  6. [名前] リストから kaiser0 を選択し、[ウィンドウ ビューアー] プロットで強調表示されるようにします。[長さ]10[ベータ]6 に設定します。[適用] をクリックします。

  7. [名前] リストから kaiser3 を選択します。[長さ]20 のままとし、[ベータ]6 に設定します。[適用] をクリックします。

  8. [名前] リストから kaiser6 を選択します。[ベータ]6 のままとし、[長さ]40 に設定します。[適用] をクリックします。

  9. [名前] リストから kaiser3 を選択します。[凡例を表示] ボタン をクリックします。

WinTool を使用して、既定の 64 サンプルのハミング ウィンドウのサイドローブを可視化します。

  1. [表示] メニューで、[時間領域] の選択を解除して [解析パラメーター] をクリックします。

  2. ダイアログ ボックスで、以下のパラメーターを指定します。

    • [点数] に「8192」と入力。

    • [周波数単位]Hz に設定。

    • [サンプリング周波数]500 Hz に設定。

    • [正規化振幅] を選択。

  3. [OK] をクリックしてダイアログ ボックスを閉じます。[X 軸ズーム] ボタン をクリックします。10 Hz ~ 35 Hz の領域を拡大し、ウィンドウの最初の 2 つのサイドローブを詳細表示します。

参考

|

R2006a より前に導入

この情報は役に立ちましたか?