ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

colormapeditor

カラーマップ エディターを開く

構文

colormapeditor

説明

colormapeditor は、カラーマップ エディター内で四角形のセルから構成されるストリップとして、現在の Figure のカラーマップを表示します。ノード ポインターとは、カラーマップ ストリップの下に表示される色付きのセルで、カラーマップ内で R、G、B 値の構成比が変化する点を示します。[[色空間の内挿] セレクターを HSV に設定すれば、HSV 色空間で操作することもできます。

カラーマップ エディターは、[編集] メニューから[カラーマップ] を選択しても起動できます。

ノード ポインターの操作

ノード ポインターを選択および移動することで、カラーマップにおける色の範囲を変化させることができます。ノード ポインターの色は移動しても変わりませんが、カラーマップは、ノード間で RGB 値を線形内挿することにより変化します。

ノード ポインターをダブルクリックして、ノード位置における色を変更できます。カラー ピッカーが表示されるので、そこから新しい色を選択することができます。ノード位置における新しい色を選択すると、ノード間の色が再内挿されます。

GUI の [ツール] メニューの [標準のカラーマップ] を使用すると、異なるカラーマップを選択できます。プロット ツールのプロパティ エディターには標準のカラーマップから選択できるドロップダウン メニューがありますが、ここでカラーマップを変更することはできません。

操作

実行方法

組み込みカラーマップを選択

[ツール][標準のカラーマップ]

ノードを追加

カラーマップ ストリップ内の対応するセルの下をクリックします。

ノードを選択

ノードを左クリックします。

複数のノードを選択

隣接する場合: 最初のノードを左クリックし、最後のノードを Shift キーを押しながらクリックします。

離れている場合: 最初のノードを左クリックし、以降のノードを Ctrl キーを押しながらクリックします。

ノードを移動

マウスで選択してドラッグするか、選択して左矢印キーと右矢印キーを使用します。

複数のノードを移動

複数のノードを選択し、左矢印キーと右矢印キーを使ってグループとしてノードをグループで移動します。選択したノードの 1 つが選択されていないノードか末端のノードに達した時点で移動は終了します。

ノードを削除

ノードを選択し、Delete キーを押すか、[編集] メニューから [削除] を選択するか、あるいは Ctrl + x キーを押します。

複数のノードを削除

ノードを選択し、Delete キーを押すか、[編集] メニューから [削除] を選択するか、あるいは Ctrl + x キーを押します。

ノードに対してカラー ピッカーを表示

ノード ポインターをダブルクリックします。

現在の色情報

カラー セルあるいはノード ポインターにマウス ポインターを合わせると、カラーマップ エディターは、そのカラーマップ要素に関して以下の情報を表示します。

  • カラーマップにおける要素のインデックス

  • そのノードの色にマッピングされているグラフィックス オブジェクト カラー データからの値 (Figure 内にある image、patch、あるいは surface オブジェクトの CData プロパティから得られたデータ)

  • 色の RGB および HSV 色値

色空間の内挿

色空間は、ノード間のセルの色を計算するために使用される値を決定します。たとえば、RGB カラー空間の場合、ノード間の色は、あるノードと以下のノードがもつ赤、緑、青の強度値を線形内挿することによって計算されます。色空間を HSV に切り替えると、カラーマップ エディターは色定義における色相、彩度、明度の成分を使って、ノード間の色を再計算することになります。

ある色空間から別の色空間へ切り替える場合、カラーマップ エディターは、ノード ポインターの数、色、位置を保持します。これによってカラーマップの変更が可能になります。

HSV での内挿-  色相は概念上、色の円を回る形でマッピングされるため、色相値の間の内挿は理解しにくい場合があります。このあいまいさを最小限に抑えるため、内挿では円を回る最短距離を使用します。たとえば、色相 2 (わずかにオレンジがかった赤) と色相 356 (わずかにマゼンタがかった赤) の 2 つのノード間における内挿は、色相 3、4、5、... 353、354、355 (オレンジがかった赤-黄-緑-シアン-青-マゼンタ/赤) という変化にはなりません。円を回る最短距離を採用するため、357、358、1、2 (オレンジ/赤-赤-マゼンタ/赤) という変化になります。

カラー データの最小と最大

[最小カラー データ] および [最大カラー データ] というテキスト フィールドを使用すると、座標軸の CLim プロパティの値を指定できます。これらの値は、オブジェクト カラー データ (image、patche、および surface の CData プロパティ) からカラーマップへのマッピングを変更します。

この例では、データ値の範囲が色の指定範囲で表示されるように、既定の MATLAB® カラーマップを変更します。使用するグラフは、ジェット ノズルを通して排出される流量の断面を描くスライス平面です。この種のグラフの詳細は、slice のリファレンス ページを参照してください。

カラーマップの強調

この例では、データ値の範囲がより明確に表示されるように、MATLAB の既定のカラーマップを変更します。

フロー データセットのスライス平面を作成します。

[x,y,z,v] = flow;
hz = slice(x,y,z,v,[],[],0);
hz.EdgeColor = 'none';
hz.FaceColor = 'interp';
view(2)

カラーマップ エディターを起動します。

colormapeditor

フロー データの情報をより明確にするために、関心領域の色の変化を大きくします。カラー データの最大値として赤色を追加し、黄色およびオレンジ色と混合させます。

新しいカラーマップを適用すると、上位のデータ値のフロー データの変化がより明確になります。

変更したカラーマップの保存

変更したカラーマップは、関数 colormap あるいは Figure の Colormap プロパティを使用して保存することができます。

変更内容を適用したら、現在の Figure のカラーマップを変数に保存します。

mycmap = get(fig,'Colormap'); 

このカラーマップを別の Figure で使用するには、Figure の Colormap プロパティを設定します。

set(new_fig,'Colormap',mycmap)

変更したカラーマップを MAT ファイルに保存するには、save コマンドを使用して mycmap ワークスペース変数を保存します。

save('MyColormaps','mycmap')

保存したカラーマップを別の MATLAB セッションで使用するには、この変数をワークスペースに load し、カラーマップを Figure に割り当てます。

load('MyColormaps','mycmap')
set(fig,'Colormap',mycmap)
この情報は役に立ちましたか?