ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

キーボード ショートカットの定義

キーボード ショートカット

キーボード ショートカットを使用して、デスクトップ機能にすばやくアクセスできます。Alt キーを押すと、MATLAB® ツールストリップ ボタンに関するツールヒントが表示されます。ツールヒントには、これらの機能にアクセスするために押すキーが示されます。たとえば、Alt + H と押すと [ホーム] タブに移動し、タブ上で利用できる機能のツールヒントが表示されます。これらのショートカットはカスタマイズできません。

アクションには複数のキーボード ショートカットを指定できます。定義されたすべてのショートカットが機能しますが、デスクトップ ツールストリップのツールヒントには 1 つだけが表示されます。

以下の操作を実行できます。

  • MATLAB でインストールされたショートカットから選択する

  • カスタマイズしたショートカットのセットを作成する

  • 別のシステムからコピーしたショートカットのセットを使用する

キーボード ショートカットのセットの選択

既定の設定では、MATLAB は実行しているプラットフォームに対応するキーボード ショートカット設定を使用します。別のキーボード ショートカットの設定を選択するには、次の手順に従います。

  1. [ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。

  2. [アクティブ設定] フィールドで下矢印をクリックして、この表に示すようにドロップダウン リストから選択します。

    設定ファイル 選択するオプション詳細

    MATLAB でインストール

    • Mac では、[Mac の既定設定]

    • 他のすべてのシステムでは、[Windows 既定の設定] または [Emacs 既定の設定]

    MATLAB でインストールされるファイルの説明については、インストールされているキーボード ショートカットの設定ファイルを参照してください。

    以前に追加したもの

    ファイル名

    追加情報なし

    システム上にあるが、ドロップダウン リストにはない

    参照

    キーボード ショートカット設定ファイルの参照.

  3. [適用] をクリックします。

インストールされているキーボード ショートカットの設定ファイル

次の表は、MATLAB にインストールされているキーボード ショートカットの設定ファイルを示しています。

オペレーティング システムMATLAB と共にインストールされるキーボード ショートカットの設定ファイル
Windows®
  • Windows 既定の設定 (既定)

  • Emacs 既定の設定

UNIX®
  • Emacs 既定の設定 (既定)

  • Windows 既定の設定

Macintosh
  • Macintosh 既定の設定 (既定)

キーボード ショートカット設定ファイルの参照

参照して、システム上に存在するが、[キーボード ショートカット設定] ダイアログ ボックスの [アクティブ設定] にはない、キーボード ショートカット設定ファイルを使用します。これは、設定ファイルを別のシステムから prefdir ディレクトリ以外のフォルダーにコピーした場合に発生する状況です。設定ファイルを参照してアクティブな設定ファイルにするには、以下のステップに従います。

  1. [ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。

  2. [アクティブ設定] フィールドで、下矢印をクリックし、[参照] を選択します。

  3. [開く] ダイアログ ボックスで、設定ファイルを格納したフォルダーに移動します。

  4. 設定ファイルを選択し、[開く] をクリックします。

  5. [キーボード ショートカット設定] ペインで [OK] をクリックします。

    ステップ 4 で選択した設定ファイルが MATLAB のアクティブ設定ファイルになります。

今後の MATLAB セッションではこの設定ファイルが [アクティブ設定] ドロップダウン メニューにオプションとして追加されます。

File Exchange からのキーボード ショートカット設定ファイルの使用

以下のいずれかを実行する場合は、File Exchange からキーボード ショートカット設定ファイルをダウンロードします。

  • MATLAB Version 7.9 (R2009a) 以前のリリースに配置された MATLAB の既定のキーボード ショートカットに戻す

  • その他のユーザーが作成して File Exchange にアップロードしたキーボード ショートカットを見つけてダウンロードする

次の手順に従います。

  1. 使用するキーボード ショートカット セットを File Exchange Web サイトで検索します。keyboard shortcuts configurable のタグが付いたファイルには次のものがあります。

    • MATLAB Desktop R2009a 既定以外のキーボード ショートカット セット

    • MATLAB Desktop R2009a 既定のキーボード ショートカット セット

  2. ファイルの説明を確認するには、ファイルの提出名をクリックします。

  3. [Download Submission] ボタンをクリックして .ZIP ファイルをコンピューターに保存します。

  4. MATLAB の現在のフォルダー ブラウザーで、保存したファイルの場所に移動します。ダインロードした .ZIP ファイルを右クリックして、[Extract] を選択します。

    MATLAB は .ZIP ファイルと同じ名前でサブフォルダーを作成し、ファイルをこの .ZIP ファイルから新しく作成したフォルダーに解凍します。

  5. 現在のフォルダー ブラウザーで、新しく作成したフォルダーを展開し、使用する設定ファイルをダブルクリックします。

    有効なキーボード ショートカット設定ファイルには、ファイル名の前にキーボードのキー アイコン が表示されます。

  6. [キーボード ショートカット設定] ダイアログ ボックスで、設定を確認して [OK] をクリックします。

新しくダウンロードした設定ファイルが有効になります。

キーボード ショートカット セットの比較

以下の目的で、キーボード ショートカットのセットを比較します。

  • Version 7.9 (R2009b) より前のバージョンから MATLAB をアップグレードする

    MATLAB Version 7.9 では、キーボード ショートカットがデスクトップ全体で統一されました。したがって、Version 7.9 より前に使用していたショートカットとは異なることがあります。

  • File Exchange でのキーボード ショートカット セットと現在のキーボード ショートカット セットとの違いを確認する

  • 任意のキーボード ショートカット セットと既定のセットとの違いを確認する

キーボード ショートカットの比較手順

現在のキーボード ショートカット セットを別のセットと比較するには、以下の手順に従います。

  1. [ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。

  2. [アクション] ボタン をクリックします。

  3. ドロップダウン メニューから、現在のセットと比較するキーボード ショートカット セットを選択します。

  4. 比較ツールが開き、2 つのキーボード ショートカット セットが並べて表示されます。

キーボード ショートカット セットの比較結果の解釈

キーボード ショートカット セットを比較するとき、セットは比較ツールに次のように表示されます。

  • 一方のセットはツールの左側、他方のセットは右側に表示されます。

  • 各列見出しには、その列内のキーボード ショートカット セットの名前が表示されます。

  • 次の項目が異なる行は、わかりやすくするために強調表示されます。

    • 一方のファイルには存在しても他方のファイルには存在しない行は、緑色で強調表示

    • 両方のファイルに現れても内容が異なる行は、ピンクで強調表示

  • 1 つのデスクトップ アクションについて、同じキーボード ショートカットを複数のデスクトップ ツールがサポートしている場合は、ツールごとに 1 行存在します。たとえば、MATLAB デスクトップとエディターの両方が、選択されたウィンドウを閉じるという操作に対してキーボード ショートカット Ctrl + W をサポートしている場合、比較ツールのある列は次のように表示されることがあります。

  • 1 つのツールの同じアクションに対して複数のキーボード ショートカットがある場合は、キーボード ショートカットごとに 1 行存在します。たとえば、コード アナライザーの自動修正の適用に対してエディターに 2 つのキーボード ショートカットがある場合、比較ツールのある列は次のように表示されることがあります。

  • Macintosh プラットフォームでは、キーボード ショートカットのテキスト形式は、他のプラットフォームとは少し異なっており、MATLAB デスクトップ メニューで表示されている表現とも異なります。このような違いが生じるのは、Macintosh プラットフォームでは記号を使用してショートカットを表示しているからです。たとえば、Macintosh プラットフォームではあるキーボード キーに対して記号 を使用します。比較ツールでは、記号を文字列として表現するので、記号 を CMD として指定することになります。

比較ツールの機能の使い方も参照してください。

キーボード ショートカットの表示

以降の節では、キーボード ショートカットを表示できるさまざまな方法について説明します。

1 セット内のすべてのキーボード ショートカットの一覧表示

キーボード ショートカットのセットからすべてのキーボード ショートカットをコピーして、テキスト ファイルや Microsoft® Excel® などのスプレッドシート アプリケーションに貼り付けることができます。簡単に参照したり後で参照したりするためにキーボード ショートカットのリストを作成するには、以下の手順に従います。

  1. [ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。

  2. [アクション] ボタン をクリックします。

  3. ドロップダウン メニューから、[クリップボードにコピー] を選択します。

  4. スプレッドシート アプリケーションまたはテキスト エディターを開きます。

    書式設定を最適化するため、スプレッドシート アプリケーションを使用してください。

  5. クリップボードのデータを貼り付けます。

    たとえば Microsoft Excel では、[ホーム][貼り付け] を選択します。

メニュー上のキーボード ショートカットの表示

メニューにキーボード ショートカットが表示されない場合は、現在そのアクションに対して存在していません。アクションに対してキーボード ショートカットを作成するには、キーボード ショートカットのカスタマイズの手順に従ってください。

[設定] ダイアログ ボックスでのキーボード ショートカットの表示

アクションに対してメニュー オプションがない場合にキーボード ショートカットを特定するには、[キーボード ショートカット設定] ペインを使用して、次の手順を実行します。

  1. [ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。

  2. フィルター フィールドに、キーボード ショートカットを一覧表示するツールの名前を入力します。たとえば、「Editor」と入力して、エディターで実行できるアクションに現在定義されているキーボード ショートカットを確認します。

  3. アクションを説明する文字列を追加して、設定ペインに表示される [アクション名] の一覧を絞り込みます。たとえば、エディターで選択したテキストを消去するためのキーボード ショートカットを探す場合は、「clear」を追加します。検索するアクションを返すフィルターの可能性を高めるには、短い文字列を入力します。

  4. 目的のアクション名を選択します。この例では、[選択をクリア] を選択します。

  5. [選択をクリアのショートカット] というラベルが付いた表を表示します。これは、Escape キーが、エディターの [選択をクリア] アクションに対する現在のキーボード ショートカットであることを示します。

キーボード ショートカットのカスタマイズ

MATLAB デスクトップ ツールのキーボード ショートカットをカスタマイズまたは表示することができます。[ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。インターネット接続がアクティブな場合、カスタマイズ可能なキーボード ショートカットのビデオカスタマイズ可能なキーボード ショートカットのビデオで概要を見ることができます。

以下の節では、次のアクションの詳細を説明します。

キーボード ショートカットのカスタマイズ手順

  1. [ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。

  2. [アクティブ設定] フィールドで、カスタマイズするキーボード ショートカットのセットを含むファイルを選択します。

    通常、キーボード ショートカットを初めて変更するときは、プラットフォームの既定の設定から開始します。詳細は、キーボード ショートカットのセットの選択を参照してください。

  3. [アクション名] の下で、キーボード ショートカットを定義または変更するアクションを選択します。アクションは、[コマンド履歴のクリア] のように、ショートカットをカスタマイズする操作です。

    必要なアクションの検索のヒントは、キーボード ショートカット アクションのフィルター処理を参照してください。

  4. [追加] ボタン をクリックします。

    編集可能なフィールドが [ショートカット] 列の下で開きます。

  5. 手順 3 で選択したアクションに使用するショートカットを入力します。または、ドロップダウン メニューからショートカットを選択できます。

    詳細は、キーボード ショートカットのキーストロークの指定を参照してください。

  6. ショートカットを、使用したいツールに割り当てます。たとえば、[ショートカットが利用できるツール] 列で、次の手順を実行します。

    1. ショートカットを割り当てることができるデスクトップ ツールの一覧の下矢印 をクリックします。すべてのアクションがすべてのデスクトップ ツールで使用できるわけではありません。

    2. ショートカットをツールに割り当てるには、チェック ボックスをオンにします。ショートカットを削除するには、チェック ボックスをオフにします。

  7. 競合を評価し、解決します。競合は情報アイコン またはエラー アイコン で示されます。

    詳細は、キーボード ショートカットの競合の評価と解決を参照してください。

  8. [適用] をクリックします。

    • キーボード ショートカットがすぐに使用できるようになります。

    • これまでキーボード ショートカットが表示されなかったメニュー オプションに対応するショートカットを変更した場合、MATLAB ではメニューに新しいキーボード ショートカットが反映されます。

既定のキーボード ショートカット セットの復元

キーボード ショートカットを変更しても、その変更を維持しない場合は、既定のショートカットに戻すことができます。キーボード ショートカットの既定状態に戻すには、以下の手順に従います。

  1. [アクション] ボタン をクリックします。

  2. システムに応じて、[Windows の修正を元に戻す][Emacs の修正を元に戻す] を選択します。

  3. [OK] をクリックします。

    メモ:   変更内容を元に戻すと、セットに対して行われたキーボード ショートカットへの変更がすべて元に戻ります。ショートカットごとに変更を元に戻すことはできません。

設定ファイルへのキーボード ショートカットの保存

キーボード ショートカットを設定ファイルに保存すると、次の操作を実行できます。

  • [Windows 既定の設定] などの既定の設定ファイルに行った変更を新しいセットに保存する

    MATLAB は、複数のセッション全体で既定のセットに加えられた変更内容を保存します。ただし、既定のキーボード ショートカット セットに対する変更内容を元に戻した場合 (既定のキーボード ショートカット セットの復元を参照)、新しいセットに最初に保存しないかぎり、変更内容はすべて失われます。

  • キーボード ショートカット設定ファイルを MATLAB を実行している別のシステムにコピーして、そこで使用する

  • 以前に保存した設定ファイルを上書きする

    MATLAB にインストールされる既定の設定ファイルを上書きすることはできません。MATLAB は、テキスト (変更) が追加された既定の設定の名前を使用して、既定の設定に行った変更を保存します。たとえば、Windows 既定の設定 (変更済) のようになります。

  • キーボード ショートカット設定ファイルを他のユーザーと共有する

    たとえば、自作のファイルを File Exchange リポジトリに提出することができます。ファイルを送信できるページに直接移動するには、次のリンクをクリックしてください。MATLAB Central File Exchange — Submit New File.

キーボード ショートカットの設定ファイルを保存するには、次の手順に従います。

  1. [キーボード ショートカット設定] ダイアログ ボックスを開きます。[ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。

  2. [アクション] ボタン をクリックし、[名前を付けて保存] を選択します。

  3. [保存] ダイアログ ボックスで、ファイルを保存するフォルダーに移動し、ファイル名を指定して、[保存] をクリックします。

    MATLAB は、指定されたフォルダーにファイルを .xml ファイルとして保存します。

キーボード ショートカット アクションのフィルター処理

フィルター フィールドを使用し、キーボード ショートカットをカスタマイズまたは定義できるアクションの一覧を確認します。

  1. 以下のいずれかのすべてまたは一部を入力します。

    • [削除] などのアクション名

      MATLAB には、指定したテキストを含むアクション名またはデスクトップ メニューのみが表示されます。

    • [ファイル][コマンド ウィンドウ] などのデスクトップ ツールまたはメニューの名前

      MATLAB には、指定されたツールまたはメニューに関連付けられたアクション名の一覧が表示されます。さらに、一覧には、ツールまたはメニューの名前を含むアクション名が含まれます。たとえば、[コマンド履歴] を指定すると、アクション名の一覧にコマンド ウィンドウのアクションである [次の履歴コマンド] が含まれます。

    • Ctrl + R などのキーボード ショートカット

      MATLAB には、指定したショートカットをもつアクション名のみが表示されます。以下の点に注意してください。

      • キーストロークまたはキー名の入力によって、ほとんどのキーボード ショートカットを入力できます。

        たとえば、Ctrl + S を入力するには、キーストロークを使用します (Ctrl キーを押しながら S キーを押す)。または、一文字ずつ "Ctrl+S" と入力します (C-t-r-l-+-Y)。

      • キーボード ショートカットのキーストロークでうまくいかない場合は、文字の入力を試してみてください。キーボード ショートカットのなかには、一文字ずつ入力しなければならないものもあります。たとえば、TabBackspaceDel キーなどのショートカットです。

      • 一部のキーボードの右端にあるテンキーを参照するには、"numpad" と入力します。

      • キーパッドの上方向キーと下方向キーを参照するには、それぞれ" Up" と "Down" と入力します。

  2. [アクション名] が予想どおりのアクションを実行するかどうかを確認します。

    1. [アクション名] の上にマウス ポインターを置きます。たとえば、[次の単語を削除] など。

    2. 表示されるツールヒントを確認します。

キーボード ショートカットのキーストロークの指定

"キーストローク" は、単独のキーでも、あるいは修飾キー (AltShift、およびCtrl) と別のキーとの組み合わせでもかまいません。キーボード ショートカットを作成するときには、ショートカットのキーストロークを次のように指定します。

  1. [追加] ボタン をクリックします。

  2. ショートカットに使用するキーストロークの数を指定します。

    • 既定のキーストローク数 (1) を使用するには、「手順 3」に進みます。

    • 複数のキーストロークを指定する、または 1 つのキーストロークを明示的に指定するには、次の手順に従います。

      1. [ショートカット] フィールドのキー アイコン の隣にある下矢印をクリックします。

      2. [1 キーストロークに制限][2 キーストロークに制限]、または [3 キーストロークに制限] を選択します。

        たとえば、Ctrl + F は 1 回のキーストローク、Ctrl + YShift + Z は 2 回のキーストローク、Ctrl + YShift + ZF9 は 3 回のキーストロークです。

  3. 次のいずれかを行って、キーストロークを指定します。

    • キー名を一文字ずつ入力するのではなく、キーを押して、キーストロークを入力する

      たとえば、Ctrl キーと Y キーを押します。Ctrl+Y のように 1 文字ずつ入力しないでください。

    • [ショートカット] フィールドのキー アイコン の隣にある下矢印をクリックして、Tab キーなどのキーストロークを選択する。次に、キー名を選択する

      一覧表示されたキーには、ダイアログ ボックス内で定義済みのアクションがあります。たとえば、Tab キーは、ダイアログ ボックス内で次のフィールドに移動します。

キーボード ショートカットの競合の評価と解決

2 つ以上の異なるアクションのショートカットが同じだと、競合が発生します。キーボード ショートカットの競合を解決する必要はありません。ただし、同じショートカットが 2 つの異なるアクションを指定していると、ショートカットの使用が紛らわしい場合があります。

キーボード ショートカットの競合の表示 — [ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。

[キーボード ショートカット設定] ペインに、情報アイコン とエラー アイコン を使用して競合が示されます。

同じショートカットが設定された異なるツールのアクション — 競合の評価

通常、以下のすべての条件が当てはまる場合、情報アイコン で示された競合を解決してください。

  • 両方のツールを頻繁に使用する

  • 両方のアクションを頻繁に実行する

  • ショートカットが各ツールで実行するアクションを覚えるのが困難である

たとえば、Microsoft Windows プラットフォームでは、既定で、Ctrl + Shift + U は MATLAB デスクトップからツールをアンドックします。ただし、エディターでテキストを選択し、Ctrl + Shift + U を押すと、選択したテキストが大文字に変更されます。これらの両方のアクションを頻繁に使用する場合、いずれかまたは両方のアクションに別のキーボード ショートカットを指定できます。

同じショートカットが設定された同じツールのアクション — 競合の評価

通常、エラー アイコン で示された競合を解決してください。

以下の条件の 1 つ以上が当てはまる場合は、これらの競合を解決する必要はありません。

  • 状況が一時的である

    たとえば、2 ステップの手順を実行しているとします。最初のステップで、キーボード ショートカットを競合するアクションに割り当てます。次に、2 つ目のステップで、元のアクションからショートカットを削除します。

  • 2 つのアクションが同じツールの異なるモードに関連付けられている

    既定の設定では、MATLAB エディターがセル モードである場合、Ctrl + UpCtrl + Down は、それぞれ次のセルと前のセルにカーソルを移動します。エディターがセル モードでない場合、これらのキーボード ショートカットはそれぞれ上と下にスクロールします。ショートカットは競合していますが、動作は、特定の MATLAB エディター モードに対しておそらく予期したものになります。

    設定ペインからは明らかではありませんが、Windows システム上では Ctrl + C で同じような状況になります。Ctrl+C は、MATLAB の実行を中断するキーボード ショートカットです。ただし、コピー アクションの既定のキーボード ショートカットも Ctrl + C です。したがって、次のようになります。

    • 項目を選択し、Ctrl + C を押すと、MATLAB がビジー状態であるかどうかに関係なく、選択した項目がクリップボードにコピーされます。

    • 項目を選択して Ctrl + C を押さないでください。MATLAB の実行が中断されてしまいます。

    コピー アクションの既定のキーボード ショートカットを Ctrl + C から別のキーストロークに変更すると、項目を選択したかどうかに関係なく、Ctrl + C によって MATLAB の実行が中断します。

キーボード ショートカットの競合の解決

競合を解決するには、ショートカットを変更または削除して、ショートカットと頻繁に使用されるアクションが 1 対 1 で対応するようにします。例については、キーボード ショートカットの変更キーボード ショートカットの削除を参照してください。

キーボード ショートカットの作成、変更、および削除の例

新しいキーボード ショートカットの作成

既定の設定では、ヘルプ トピックからお気に入りのリストに追加するためにキーボード ショートカットは使用できません。トピックをお気に入りとして頻繁にマークする場合、次のようにしてこのアクションにキーボード ショートカットを定義できます。

  1. [ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。

  2. フィルター フィールドに「Help」と入力します。

  3. [アクション名] の一覧をスクロールし、[お気に入りに追加] を選択します。

  4. プラス ボタン をクリックします。

    MATLAB は、プラス ボタンの上の表に行を追加します。

  5. [ショートカット] フィールドで、下矢印をクリックし、[1 キーストロークに制限][2 キーストロークに制限] に変更します。

  6. [ショートカット] フィールドで、Ctrl + S を押して、Alt + V を押します。

    [競合しているショートカット] の表は空で、これは、現在このキーストロークの組み合わせを使用している他のデスクトップ アクションはないことを意味します。

  7. [適用] をクリックします。

次の点に注意してください。

  • [お気に入りに追加] ダイアログ ボックスは、ヘルプ ブラウザーで Ctrl + SAlt + V を押すと開きます。

  • Ctrl+SAlt+V は、ヘルプ ブラウザーの [お気に入り] メニューをクリックすると [お気に入りに追加] の隣に表示されます。

キーボード ショートカットの変更

MATLAB エディターでインデント処理を頻繁に調整するとします。ただし、インデントを減らすための Ctrl + [ の既定のキーボード ショートカットを覚えるのが困難だとします。そこで、そのキーボード ショートカットを覚えやすいものに変更することにしました。

この例では、MATLAB エディターで [インデントを減らす] のキーボード ショートカットを Ctrl + [ から Ctrl + Backspace に変更します。

  1. [ホーム] タブの [環境] セクションで、[設定][キーボード][ショートカット] をクリックします。

  2. [アクティブ設定] の下で、[Windows 既定の設定] を選択します。

  3. フィルター フィールドで、Ctrl + [ を押します。

  4. [アクション名] の下で、[インデントを減らす] を選択します。

  5. [インデントを減らすのショートカット] というラベルが付いた表の [ショートカット] の下で、[Ctrl + [] をクリックします。MATLAB は、フィールドを編集可能にします。

  6. [ショートカット] フィールドで、Ctrl + Backspace を 2 回押します。

    このキーの組み合わせを 1 回押すと、[Ctrl+[] が削除されます。もう一度押すと、フィールドに [Ctrl+Backspace] が表示されます。

  7. [適用] をクリックします。

    MATLAB は、変更を [Windows 既定の設定 (変更済)] の設定に保存します。

キーボード ショートカットの削除

キーボード ショートカットを頻繁に押し間違えることがあるとします。たとえば、Windows で、MATLAB エディターの現在のセルを評価しようとして、Ctrl + Enter ではなく、Alt + Enter (コード アナライザー自動修正の適用) を押してしまうとします。自動修正を誤って適用することを防ぐには、以下の手順に従って Alt + Enter を削除します。

  1. [ホーム] タブの [環境] セクションで、 [設定] をクリックします。[キーボード][ショートカット]を選択します。

  2. [アクティブ設定] の下で、[Windows 既定の設定] または [Windows 既定の設定 (変更済)] を選択します。

  3. フィルター フィールドで Alt + Enter を押します。

  4. [アクション名] の下で、[メッセージの自動修正] の行を選択します。

  5. [メッセージの自動修正のショートカット] 下の次の表で、Alt + Enter キーの行を選択します。

  6. [削除] ボタン をクリックします。

  7. [適用] をクリックします。

    存在しない場合は、[Windows 既定の設定 (変更済)] キーボード ショートカット設定が作成されます。この設定は、Alt + Enter のショートカットより少ないキーボード ショートカットの [Windows 既定の設定] で構成されます。[Windows 既定の設定 (変更済)] の設定ファイルが存在する場合は、その設定のキーボード ショートカットから Alt + Enter が削除されます。

キーボード ショートカット セットの削除も参照してください。

キーボード ショートカット セットの削除

キーボード ショートカット セットを以前にシステムに保存したかまたはコピーしたことがあり、不要になった場合、以下の手順に従って削除します。

  1. [ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。

  2. [アクティブ設定] で、削除するキーボード ショートカットのセットを選択します。

    既定のキーボード ショートカット セット (Windows Default Set) は削除できません。

  3. [アクション] ボタン をクリックし、["ファイル名" の削除] を選択します。ただし、"ファイル名" は以前にシステムに保存またはコピーしたことがあるキーボード ショートカット セットの名前です。

維持するキーボード ショートカット セットから 1 つのキーボード ショートカットだけを削除する方法は、キーボード ショートカットの削除を参照してください。

他のシステムで作成されたキーボード ショートカットの設定ファイルの使用

便利なキーボード ショートカットの設定ファイルを見つけた場合や別のシステムで作成した設定ファイルを使用する場合は、次のようにしてそれをアクティブな設定ファイルにすることができます。

  1. 次のようなシステム上のフォルダーに設定ファイルをコピーします。

    I:\my_matlab_files\active_settings_files\new_settings.xml
  2. [ホーム] タブの [環境] セクションで、 [設定] をクリックします。[MATLAB][キーボード][ショートカット] を選択します。

  3. [アクティブ設定] フィールドで、下矢印をクリックし、[参照] をクリックします。

  4. [開く] ダイアログ ボックスで、設定ファイルをコピーしたフォルダーに移動します。

  5. 設定ファイルを選択し、[開く] をクリックします。

  6. [キーボード ショートカット設定] ペインで [適用] をクリックします。これで、指定した設定ファイルが MATLAB のアクティブな設定ファイルになります。

キーボード ショートカットの制約

次の節では、キーボード ショートカットを変更できないツール、ツールの一部、およびアクションについて説明します。

キーボード ショートカットをカスタマイズできないツール

次のツールまたはツールの一部に関連付けられているキーボード ショートカットは変更できません。

  • Figure ウィンドウ — たとえば、MATLAB の .fig ファイルを保存するためのキーボード ショートカット Ctrl + S は変更できません。

  • ツール ボックス — たとえば、SimBiology® デスクトップのキーボード ショートカットは変更できません。

  • インクリメンタル検索 — 順方向または逆方向にインクリメンタル検索を開始するためのキーボード ショートカットは変更できます。ただし、順方向に検索する Ctrl + Shift + S など、インクリメンタル検索モード内で使用するキーボード ショートカットは変更できません。

  • ダイアログ ボックス — たとえば、[OK] ボタンのキーボード ショートカットを作成することはできません。

キーボード ショートカットをカスタマイズできないアクション

次の表では、キーボード ショートカットをカスタマイズできない頻繁に使用するアクションについて説明します。

アクション

キーボード ショートカット

現在のアクションをキャンセルする

Esc (エスケープ)

たとえば、[編集] メニューを選択した場合、メニュー項目が表示されます。Esc を押すと、メニュー項目は閉じます。

関数ブラウザーで Esc を 3 回押すと、次のような結果になります。

  1. 検索履歴が閉じる

  2. 検索フィールドがクリアされる

  3. 関数ブラウザーが閉じる

サポートされているすべてのプラットフォーム上の MATLAB の実行を中断する

Ctrl + C

Windows システムと UNIX システム上の MATLAB の実行を中断します。

Ctrl + Cancel

Macintosh システム上の MATLAB の実行を中断する。

Cmd + . (ピリオド)

Windows システムと UNIX システム上のコンテキスト メニューを開く

Ctrl + Shift + F10

デスクトップを閉じ、MATLAB を終了する。デスクトップ外で、アクティブ ウィンドウを閉じる (Macintosh プラットフォーム以外)。

Alt + F4

ユーザー補助機能

たとえば、ダイアログ ボックスのフィールドを移動するための Tab キーなど。

開いているツールをアクティブなツールにする

  • コマンド ウィンドウ: Ctrl + 0

  • コマンド履歴: Ctrl + 1

  • 現在のフォルダー: Ctrl + 2

  • ワークスペース: Ctrl + 3

  • プロファイラー: Ctrl + 4

  • Figure パレット: Ctrl + 6

  • プロット ブラウザー: Ctrl + 7

  • プロパティ エディター: Ctrl + 8

  • エディター: Ctrl + Shift + 0

  • Figure: Ctrl + Shift + 1

  • Web ブラウザー: Ctrl + Shift + 2

  • 変数エディター: Ctrl + Shift + 3

  • 比較ツール: Ctrl + Shift + 4

  • ヘルプ ブラウザー: Ctrl + Shift + 5

この情報は役に立ちましたか?