ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

グラフの注釈方法

グラフ注釈機能

テキストやその他の説明用素材を使用してグラフに注釈を付けると、グラフの情報を詳細に伝えることができます。MATLAB® グラフィックス ツールにはさまざまなグラフ注釈機能が含まれており、それらの機能を使用すると、以下のことを実行できます。

  • テキスト、ライン、矢印、四角形、楕円、その他の注釈オブジェクトを Figure 上の任意の場所に挿入する

  • データ空間内の場所に注釈を固定する

  • 凡例とカラーバーを挿入する

  • 軸ラベルとタイトルを挿入する

  • グラフィックス オブジェクトのプロパティを編集する

プロット編集ツール バー上の注釈ツール

[表示] メニューから [プロット編集ツール バー] を選択して、ツール バーを表示します。

Figure パレット上の注釈ツール

基本注釈ツールは、Figure パレットから利用可能です。[表示] メニューから [Figure パレット] を選択して、Figure パレットを表示します。

挿入メニューから注釈の挿入

注釈機能は、[挿入] メニューにあります。

コマンド インターフェイス

MATLAB コマンドを使って、注釈を挿入できます。以下の表は、注釈作成に使用される関数の一覧です。

注釈を作成するための MATLAB 関数

関数

目的

annotation

ライン、矢印、テキスト矢印、双方向矢印、テキスト ボックス、四角形、楕円を含む注釈の作成

xlabel, ylabel, zlabel

各軸へテキスト ラベルを挿入

title

グラフにタイトルを挿入

colorbar

グラフにカラーバーを挿入

legend

グラフに凡例を挿入

注釈の削除

注釈は手動、および (明示的なハンドルがある場合は) プログラム的に削除することができます。詳細は、MATLAB 関数リファレンス ドキュメンテーションの注釈の削除を参照してください。

四角形または楕円でグラフの領域を囲む

グラフの特定の領域に注意を向けるために、四角形や楕円を挿入することができます。どちらのオブジェクトも、そのオブジェクトを選択して、移動やサイズ変更を行ったり、右クリックで表示されるコンテキスト メニューを使用して動作や外観を変更したりできます。

プロット編集ツール バーで、該当するボタンをクリックし、四角形または楕円を挿入します。

または、[挿入] メニューから [四角形] または [楕円] を選択します。カーソルが十字形に変わります。カーソルがこの状態になると、マウスの左ボタンをクリックしたままドラッグしてから離すという操作を行って、オブジェクトのサイズや形状を定義できます。

四角形と楕円の固定

Figure 内の特定の点に四角形を固定することで、その点に取り付けることができます。四角形の固定方法は 3 種類あります。

  • 四角形を右クリックして、コンテキスト メニューを表示します。[軸に固定する] を選択して、ピンを既定の位置に設定します。

  • Figure ツール バーの [ピン] ボタンをクリックします (「グラフ内の一点に固定」を参照してください)。

  • [ツール] メニューから [軸に固定する] を選択します。カーソルがピンに変化します。オブジェクト内の任意の場所をクリックして、ピンをその位置に設定します。

既定では (上記の 1 つ目のオプションを使用) 、固定すると、四角形または楕円の左下隅が軸データ単位内の現在の位置に取り付けられます。その左下隅をクリックしてアンカーを別の点までドラッグすると、取り付け点を移動できます。カーソルはドラッグしている間、ピンに変わります。固定されているときは、四角形または楕円をドラッグまたはサイズ変更することはできません。

コンテキスト メニューから四角形や楕円を修正する

四角形または楕円を右クリックして、コンテキスト メニューを表示します。

メニューは以下のオプションを含みます。

  • [切り取り][コピー][削除] — クリップボードに切り取り/コピーしたり、選択オブジェクトを削除します。

  • [軸に固定する] — 左下隅を現在の位置に固定します (取り付け点は、プロット編集モードになっている間にクリックしてドラッグすると、移動できます)。

  • [固定の解除] — 固定点から四角形の固定を解除します。

  • [面の色] — 四角形または楕円の色を塗りつぶします。

  • [エッジの色] — 四角形または楕円の描画に使用されるラインの色。

  • [ライン幅] — 四角形または楕円の描画に使用されるライン幅。

  • [ライン スタイル] — 四角形または楕円の描画に使用されるライン タイプ。

  • [プロパティ] — テキスト ボックス プロパティのあるプロパティ エディターを表示します。

  • [M コードの表示] — グラフを再作成するMATLAB コードを作成します。

四角形および楕円プロパティの設定

プロパティ エディターを使用すると、コンテキスト メニューから [プロパティ] を選択し、四角形プロパティおよび楕円プロパティを設定できます。プロパティ エディターに、前述のコンテキスト メニューの節で説明したプロパティと同じプロパティが表示されます。

プロパティ エディターの [詳細なプロパティ] ボタンをクリックすると、プロパティ インスペクターが表示されます。プロパティ インスペクターには、選択した注釈オブジェクトのすべてのプロパティが表示されます。ただし、これらのプロパティの中には、変更すると注釈オブジェクトの正常な機能に影響を与える可能性があるため、変更してはならないものもあります。各オブジェクトで変更できるプロパティの説明については、以下の節を参照してください。

テキスト ボックス注釈

テキスト ボックスは、複数行のテキストを入れることができる四角形のボックスです。テキスト ボックスを Figure 内の任意の点に固定することができます。

Figure ツール バーの [テキスト ボックス] ボタン をクリックしてテキスト ボックスを挿入してから、テキスト文字列を入れる場所をクリックします。テキスト ボックスは、既定の動作では、その中に入力されたテキストの量に合わせてサイズが変化します。テキスト入力後にテキスト ボックスのサイズを変更することや、テキスト ボックスの作成時にそのテキスト ボックスをクリックしてドラッグし、特定のサイズにすることもできます (これを行うと、テキスト ボックス内にどのくらいの量のテキストを入力しても、テキスト ボックスはそのサイズのままになります)。

[挿入] メニューから [テキストボックス] を選択することもできます。

テキスト ボックス オブジェクトの選択

テキスト ボックス オブジェクトの選択は、他の注釈オブジェクトの選択とは異なります。

  • テキスト ボックスを移動するには、テキスト上で一回クリックして選択します。

  • テキスト ボックスを編集するには、ボックス内でダブルクリックします。

  • テキスト ボックス プロパティのあるプロパティ エディターを表示するには、右クリックしてコンテキスト メニューを表示し、[プロパティ] を選択します。

テキスト ボックスを固定する

Figure 内の特定の点にテキスト ボックスを固定することで、その点に取り付けることができます。テキスト ボックスの固定方法は 3 種類あります。

  • テキスト ボックス内で右クリックしてコンテキスト メニューを表示し、[軸に固定する] を選択します。

  • Figure ツール バーの [ピン] ボタンを選択し、テキストボックスのハンドルをクリックします (「グラフ内の一点に固定」を参照してください)。

  • [ツール] メニューから [軸に固定する] を選択します。

既定では、固定すると、テキスト ボックスの左下隅が軸データ領域内のその位置に取り付けられます。取り付け点を移動させるには、隅をクリックしてアンカーを別の点までドラッグします。ただし、固定されているときは、テキスト ボックスはドラッグできません。

コンテキスト メニューからテキスト ボックスを修正する

テキスト ボックスを右クリックすると、コンテキスト メニューが表示され、テキスト ボックスに対してさまざまな操作を行うことができます。以下の図では、コンテキスト メニューを使用して、テキスト ボックスの [背景色] が黄色に、[フォント] が太字に設定されています。[ボックスをテキストに合わせる] 項目がオンになっていることで示されているように、テキスト ボックスには、既定のサイズ変更動作が設定されています。

特定のサイズにドラッグせずにテキスト ボックスを作成すると、[ボックスをテキストに合わせる]が有効になり、入力または編集したテキストに合わせて、サイズが変更されます。テキスト ボックスの作成時にドラッグしたり、プロット編集モードでテキスト ボックスのハンドルのいずれかをドラッグしてサイズを変更したりすると、[ボックスをテキストに合わせる] は無効になりますが、コンテキスト メニューを使用して再度有効にすることができます。

メニューは以下のオプションを含みます。

  • [切り取り][コピー][削除] — クリップボードに切り取り/コピーしたり、テキスト ボックスを削除します。

  • [軸に固定する] — テキスト ボックスを現在の位置に固定します (プロット編集モードになっている間にテキスト ボックスをクリックしてドラッグすると、取り付け点を移動できます)。

  • [固定の解除] — 固定点からテキスト ボックスの固定を解除します。

  • [編集] — テキストを変更できるように編集モードを有効にします。編集モードは、左マウスボタンを使ってテキスト ボックスをダブルクリックしても有効にできます。

  • [ボックスをテキストに合わせる] — テキスト ボックスをサイズ変更し、テキストの範囲に合わせます(または合わせません)。

  • [テキストの色] — テキスト文字の色を設定します。

  • [背景色] — テキストを囲む四角形を指定した色で塗りつぶします。

  • [エッジの色] — テキストボックスのエッジの色です (エッジを表示するには、[ライン スタイル][なし]以外の値に設定しなければなりません)。

  • [フォント] — テキストに使用されるフォントのタイプです。

  • [インタープリター] — 文字が TeX (latex または tex) として解釈されるようにするか、あるいはリテラル文字 (none) として解釈されるようにするかを指定します。

  • [ライン幅]— テキスト ボックスのエッジ ラインの幅です。

  • [ライン スタイル]— テキスト ボックス エッジに使用されるライン スタイルです。

  • [プロパティ] — テキスト ボックス プロパティのあるプロパティ エディターを表示します。

  • [M コードの表示] — グラフを再作成するMATLAB コードを作成します。

テキスト ボックス プロパティの設定

テキスト ボックスのコンテキスト メニューから [プロパティ エディターの表示] を選択し、プロパティ エディターを使ってテキスト ボックス プロパティを設定します。これは、前述のコンテキスト メニューの節で説明されているプロパティと同じプロパティを表示します。

プロパティ エディターの [詳細なプロパティ] ボタンをクリックして、プロパティ インスペクターを表示します。プロパティ インスペクターは、すべてのテキスト ボックスのプロパティを表示します。ただし、これらのプロパティの中には、変更するとテキスト ボックスの正常な機能に影響を与える可能性があるため、変更してはならないものもあります。

変更可能なプロパティについては、リファレンス ドキュメンテーションの 「テキスト ボックス プロパティ」を参照してください。

注釈ラインと矢印

グラフにラインや 3 種類の矢印を追加して、それらを Figure 内の任意の点に取り付けることができます。3 種類の矢印は以下を含みます。

  • 片方向の矢印

  • テキスト ボックス付き矢印

  • 双方向矢印

Figure ツール バーの適切なボタン をクリックしてラインまたは矢印を挿入してから、ラインまたは矢印をクリックし、希望の点までドラッグしてマウスを離します。終点に矢印の先端が表示されます。

ラインまたは矢印を選択して、右クリックし、コンテキスト メニューを表示すると、さまざまなオプションにアクセスできます。

テキスト付き矢印の挿入

テキスト付き矢印は、テキスト ボックスと矢印を結合します。グラフ上の点にラベル付けするのに、役立ちます。矢印の上に T のある矢印ボタンを選択して、グラフにテキスト付き矢印を挿入します。テキスト付き矢印を挿入し、ボックス内にテキストを入力します。

矢印の先端の固定

矢印の先端をグラフ上の注目ポイントに取り付けてグラフをズームまたは移動すると、それに合わせてテキスト ボックスが自動的に再配置されます。

注釈の固定方法は 3 種類あります。

  • オブジェクトを右クリックしてコンテキスト メニューから [固定] を選択します。

  • プロット編集ツール バーの [ピン] ボタンを選択します (「グラフ内の一点に固定」を参照してください)。

  • [ツール] メニューから [軸に固定する] を選択します。

コンテキスト メニューからテキスト矢印を修正する

テキスト矢印を右クリックすると、コンテキスト メニューが表示され、テキスト矢印に対してさまざまな操作を行うことができます。ライン、矢印、双方向矢印のコンテキスト メニューは類似した項目を含んでいます。

  • [切り取り][コピー][削除] — クリップボードに切り取り/コピーしたり、テキスト ボックスを削除します。

  • [軸に固定する] — テキスト ボックスを現在の場所に固定します (プロット編集モード中に点をクリックしてドラッグすると固定点を移動できます)。

  • [固定の解除] — 固定点からテキスト ボックスの固定を解除します。

  • [方向の反転] - 矢印の先端やテキスト ボックスを交換したり、矢印の先端を単純な矢印のもう一方の端に移動したりします。

  • [エディット テキスト] — 編集モードを有効にして、テキスト文字を変更できるようにします。

  • [色] - テキスト文字、テキスト ボックス エッジ、矢印の色です。

  • [テキストの背景色] — テキストを囲む四角形の色です。

  • [フォント] — テキストに使用されるフォントのタイプです。

  • [ライン幅]— テキスト ボックスのエッジ ラインの幅です。

  • [ライン スタイル]— テキスト ボックス エッジに使用されるライン スタイルです。

  • [Head のスタイル] — 使用する矢印のタイプです。

  • [Head サイズ] — ポイント単位の矢印のサイズです。

  • [プロパティ] — テキスト ボックス プロパティのあるプロパティ エディターを表示します。

  • [M コードの表示] — グラフを再作成するMATLAB コードを作成します。

たとえば、下図はテキストの境界線が有効でテキスト背景色が黄色に設定されています。

ラインと矢印プロパティの設定

コンテキスト メニューから [プロパティ] を選択し、プロパティ エディターを使ってライン プロパティおよび矢印プロパティを設定します。プロパティ エディターには、前述のコンテキスト メニューの節で説明したプロパティと同じプロパティが表示されます。

プロパティ エディターの [詳細なプロパティ] ボタンをクリックして、プロパティ インスペクターを表示します。プロパティ インスペクターには、選択した注釈オブジェクトのすべてのプロパティが表示されます。しかし、注釈オブジェクトの機能に影響するため、変更すべきでないプロパティもあります。各オブジェクトで変更できるプロパティの説明については、リファレンス ドキュメンテーションの以下の節を参照してください。

グラフ内の一点に固定

固定とは、Figure 内の特定の点にオブジェクトを取り付けることです。固定すると、注釈が同じ点に関連付けられたままの状態で、Figure をパンしたり、サイズ変更したりできます。たとえば、以下の図では、双方向矢印の両端を固定することによって関連付けられている 2 つの異なるグラフ内の領域が示されています。

上の軸に対して水平方向ズームを行い ([ツール] メニューの [オプション] サブメニューから [水平方向のズーム] を選択)、グラフを移動して最初の 120 秒のデータを表示すると、双方向矢印は引き続きグラフ上の同じ場所を指します。

オブジェクトの固定

オブジェクトを固定するには、[プロット編集] ツール バーの [軸に固定する] ボタン をクリックするか、[ツール] メニューから [軸に固定する] を選択して、ピン モードを有効にします。次に固定する点をクリックします。

オブジェクトの固定を解除するには、右クリックしてコンテキスト メニューを表示し、[固定の解除] を選択します。

注釈ライン、矢印、四角形、楕円、テキスト ボックスを固定できます。

このモードが有効な場合、軸、四角形、矢印、ラインは自動的に左上端がグリッドに整列されます。これらのオブジェクトのいずれかを移動したり、サイズ変更すると、サイズや位置は次のグリッド位置にスナップされます。

この情報は役に立ちましたか?