ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

プロットの調査とカスタマイズ

近似および残差プロットの表示

それぞれの近似の Figure には、最大で 3 つのプロットを同時に表示して近似を確認できます。ツール バーまたは [表示] メニューを使用して、表示するプロットのタイプを選択します。

  • [メイン プロット] は曲線近似または曲面近似を表示。

  • [残差プロット] は近似とデータ間の誤差を表示。

  • [等高線図] は曲面近似の等高線図を表示 (曲線近似では利用不可)。

次に、曲線近似と予測範囲を含むメイン プロットと残差プロットの例を示します。

[ツール][予測範囲] を選択すると、2 つの追加曲線 (または曲面) がプロットされモデル近似の両側に予測範囲が表示されます。

表示する範囲を [なし][90%][95%][99%] または [カスタム] の中から選択します。[カスタム] を選択するとダイアログ ボックスが開き、必要な信頼度を入力できます。

近似表示のカスタマイズも参照してください。

残差プロット

残差プロットでは、近似とデータ間の誤差を表示し、外れ値を削除できます。詳細は、外れ値の削除を参照してください。次に、いくつかの外れ値が排除された残差プロットの例を示します。

表面プロットと等高線図の表示

曲面で近似する場合、メイン プロットに曲面近似が表示されます。曲線近似アプリの表面プロットでは、クリック アンド ドラッグによる回転または [3 次元回転] が既定のマウス モードです。曲線近似アプリの回転モードは MATLAB® の Figure の [3 次元回転] と同じです。曲線プロットの場合と同様にプロットを操作するマウス モードを変更できます。詳細は、ズーム、パン、データ カーソルおよび外れ値排除の使用を参照してください。

    ヒント:   回転モードに戻るには、他のマウス モードをオフにします。

ズーム、パン、データ カーソルまたは外れ値を排除のマウス モードをオンにした場合、そのモードをオフにすると回転モードに戻ります。たとえば、[ズームイン] ツール バー ボタンをもう一度クリックするとそのモードが解除され、回転モードに戻ります。

曲面近似がある場合、等高線図を使用して曲面の等高線図を調べます。等高線図は、曲線近似では利用できません。曲面近似では、等高線図を使用すると同じ高さの点を簡単に確認できます。次に例を示します。

多項式近似とカスタム近似では、[ツール] メニューを使用して予測範囲を表示することもできます。予測範囲を表示すると、2 つの追加曲面がプロットされモデル近似の両側に予測範囲が表示されます。前述の例に予測範囲を示しています。プロットに 3 つの曲面を確認できます。上下の曲面は、指定された信頼度におけるモデル近似曲面の両側の予測範囲を示しています。

必要に応じて、表面プロットを 2 次元プロットに切り替えることもできます。プロット カーソルは回転モードでなければなりません。必要に応じて、他のマウス モードを解除してください。次に、プロットを右クリックし、[X-Y][X-Z] または [Y-Z] 表示を選択するか [回転オプション] を選択します。これらのコンテキスト メニュー オプションはすべて標準の MATLAB 3 次元プロット ツールです。MATLAB グラフィックス ドキュメンテーションの「3 次元での回転」を参照してください。

ズーム、パン、データ カーソルおよび外れ値排除の使用

プロットを操作するマウス モードを変更できます。ツール バーまたは [ツール] メニューを使用して [ズーム][パン][データ カーソル] または [外れ値を排除] モードに切り替えます。

曲線近似アプリには、セッション内の各近似の Figure で選択したマウス モードが記憶されます。

ツール バーまたは [ツール] メニューを使用してプロットのマウス モードを順に切り替えます。

  • [ズームイン][ズームアウト][パン] および [データ カーソル] は標準の MATLAB プロット ツールです。

    曲面でこれらのモードをすべてオフにすると [3 次元回転] モードに戻ります。曲線近似アプリの表面プロットでは、回転が既定のマウス モードです。詳細は、表面プロットと等高線図の表示を参照してください。

  • [データ カーソル] でデータ カーソル モードを選択します。このモードでは、点をクリックして入力と出力の値を表示できます。

  • [外れ値を排除] で外れ値モードを選択します。このモードでは、点をクリックしてその点を近似から削除したり近似に含めたりすることができます。[外れ値を排除] は、近似からデータを視覚的に排除するマウス モードです。詳細は、外れ値の削除を参照してください。

近似表示のカスタマイズ

プロット表示をカスタマイズするには、ツール バー、[ツール] メニューまたは [表示] メニューを使用します。曲線近似アプリにおける複数の近似の作成も参照してください。

ツール メニューとツール バー

  • [凡例] で現在選択されている近似タブにあるすべてのプロットについて凡例の表示/非表示を切り替えます。

  • [グリッド] で現在選択されている近似タブにあるすべてのプロットについてグリッドの表示/非表示を切り替えます。

  • [ツール][予測範囲] を選択すると、表示する範囲を [なし][90%][95%][99%] または [カスタム] の中から選択できます。[カスタム] を選択するとダイアログ ボックスが開き、必要な信頼度を入力できます。

  • [座標軸の範囲] でプロットの X 軸と Y 軸の上限と下限を指定できるダイアログ ボックスを開きます。[リセット] をクリックすると既定の座標軸の範囲に戻ります。

メニューとツール バーの表示

[表示] コントロールを使用して表示をカスタマイズし、プロット、近似設定、結果、近似テーブルを表示または非表示にします。

  • [表示] メニューとツール バーで以下を使用できます。

    • [メイン プロット] で現在選択されている近似の Figure におけるメイン近似プロットの表示/非表示を切り替えます。メイン プロットのみが表示されている場合、この項目は無効になります。

    • [残差プロット] で現在選択されている近似タブにおける残差プロットの表示/非表示を切り替えます。残差プロットのみが表示されている場合、この項目は無効になります。

    • [等高線図] で現在選択されている近似タブにおける等高線図の表示/非表示を切り替えます。等高線図のみが表示されている場合、この項目は無効になります。

  • [表示][近似設定] で現在選択されている近似タブにおける近似コントロール ペインの表示/非表示を切り替えます ([近似名]、入力、近似タイプなど)。

  • [表示][近似結果] で、現在選択されている近似タブにおける [結果] ペインの表示/非表示を切り替えます。[結果] ペインを表示すると、モデル項と係数、適合度の統計量、近似についての情報メッセージを確認できます。

  • [表示][近似テーブル] で、曲線近似アプリの [近似テーブル] ペインの表示/非表示を切り替えます。

    ヒント:   次に示すように広いスペースにプロットを表示して比較するには、[表示] メニューを使用して [近似設定][近似結果][近似テーブル] ペインの表示/非表示を切り替えます。

複数の近似の同時表示も参照してください。

MATLAB の Figure への出力

曲線近似アプリでは、[ファイル][Figure に出力] を選択すると、曲線近似の結果から MATLAB の Figure を生成できます。[Figure に出力] により、現在の近似のプロットをすべて含む Figure が作成されます。さらに、対話型のプロット ツールを使用すると、近似結果を表示する Figure をプレゼンテーション用に編集し、異なる形式でエクスポートできます。

この情報は役に立ちましたか?